1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Trouble accessing panel remotely after upgrading

Discussion in 'Plesk 10.x for Windows Issues, Fixes, How-To' started by gene123, Nov 4, 2010.

  1. gene123

    gene123 Guest

    0
     
    Hello,

    We recently upgraded a system running Plesk 9.2 to Panel 10. After completing the upgrade process, we are unable to login using the old url:

    https://SERVER1.MYDOMAIN.COM:8443

    because it redirects to:

    https://SERVER1:8443/relay

    If we change this manually to SERVER1.MYDOMAIN.COM we get a 403 error page. However, browsing the control panel locally on the server works fine although it reverts to the SERVER1 host name.

    I read something that indicated that the customer and business manager might interfere of cause this issue because it enables sso. I'm fine with uninstalling this in order to get normal access the conrol panel again. I've been digging for the last couple of hours and have been unable to locate any way to change the url or uninstall the customer and business manager.

    Thanks,
    Gene
     
  2. jcgalvez

    jcgalvez Basic Pleskian

    25
    57%
    Joined:
    Dec 8, 2007
    Messages:
    84
    Likes Received:
    0
    Samething here, I just upgraded from 9.5.3 with the hope that this upgrade will fix many problems I have with plesk for windows and the first problem I have is that I'm unable to login remotely (within internet) due to the fact that I get exactly the same problem stuck un https://h10:8443/relay

    the only way to access the server is thru Remote console.

    Please advice what to do

    Javier
     
  3. JTRipper

    JTRipper Regular Pleskian

    27
     
    Joined:
    Mar 22, 2006
    Messages:
    106
    Likes Received:
    3
    Location:
    Italy
    exact same here after a fresh install on Windows 2008 64bit!
    Any clues ??
     
  4. NickySmith

    NickySmith New Pleskian

    22
    20%
    Joined:
    Jul 11, 2007
    Messages:
    6
    Likes Received:
    0
    Last edited: Nov 5, 2010
  5. NickySmith

    NickySmith New Pleskian

    22
    20%
    Joined:
    Jul 11, 2007
    Messages:
    6
    Likes Received:
    0
    Does anyone read this forum? and answer trouble issues?
     
  6. NickySmith

    NickySmith New Pleskian

    22
    20%
    Joined:
    Jul 11, 2007
    Messages:
    6
    Likes Received:
    0
    I've gone back to 9.5 until these issues are resolved.

    http://www.parallels.com/download/plesk10/ says... "Parallels Plesk Panel 10 can be used with PBAS for VPS hosting only (not Shared Hosting). Install on PBAS 3.4 only, and use this special PBAS update to support the Parallels Plesk Panel 10 license: http://kb.odin.com/en/9117. Turn off offline management for port 8443. Install the PBAS fix to support Parallels Plesk Panel 10’s random password generation: http://kb.odin.com/en/9238. For Parallels Plesk Panel 10 Shared Hosting compatibility with PBAS, please wait for Parallels Plesk Panel 10.1 (to be released on January 10, 2011)."
     
  7. NickySmith

    NickySmith New Pleskian

    22
    20%
    Joined:
    Jul 11, 2007
    Messages:
    6
    Likes Received:
    0
    Wow! I went back to 9.5 and now....

    ERROR: SWKeyExFatalError
    error: Cannot open file

    0: common_func.php3:4585
    of_get_key_by_product(string 'plesk-win')
    1: common_func.php3:4585
    getPleskKey()
    2: common_func.php3:4660
    getKeyProp(string 'demo')
    3: auth.php3:99

    Thank goodness this is not a production server.
     
  8. jcgalvez

    jcgalvez Basic Pleskian

    25
    57%
    Joined:
    Dec 8, 2007
    Messages:
    84
    Likes Received:
    0
    start -> settings -> control panels -> Network Connections -> your connection -> Properties -> Internet protocol TCP-IP -> advanced -> DNS -> "append this dns's suffixes" and put your domain there

    Happens that if the domain is not defined there or gotten from the dhcp will not work

    Javier
     
  9. JTRipper

    JTRipper Regular Pleskian

    27
     
    Joined:
    Mar 22, 2006
    Messages:
    106
    Likes Received:
    3
    Location:
    Italy
    Guys,

    just got it fixed!

    here's the way to resolve the problem in a flash:

    Just fire a command "C:\Program Files (x86)\Parallels\Plesk\bin\sso.exe -d"

    Hope it helps someone..
     
  10. jcgalvez

    jcgalvez Basic Pleskian

    25
    57%
    Joined:
    Dec 8, 2007
    Messages:
    84
    Likes Received:
    0
    Thanx JTRipper for the support, and yep it fixed, one trouble less.

    My question is: is there any manual with all those utilities within the \Plesk\bin\ directory?

    Another Question when you login to the panel do you get a 500 error?

    Thank you a lot

    Javier
     
  11. xplatform12

    xplatform12 Guest

    0
     
    The fix provided will help because it disables SSO. However, if you want to keep SSO enabled, you need to modify the SSO configuration to use the correct url. To see what the current SSO settings are, you can run:

    C:\Program Files\Parallels\Plesk\bin>sso.exe -g

    To change the url that SSO redirects to, use the following:

    C:\Program Files\Parallels\Plesk\bin>sso.exe -s -server https://<your fully qualified domain>:8443

    That will update the settings to it will redirect to where you want it to go.
     
Loading...