• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Ubuntu Plesk Install CLI Fails with - ERROR: You should have superuser privileges to install Plesk

Matt Downer

New Pleskian
When I try to run "sudo wget -O - https://autoinstall.plesk.com/one-click-installer | sh" it always stops with error "ERROR: You should have superuser privileges to install Plesk"

Ubuntu 14.04.3 LTS (GNU/Linux 3.19.0-25-generic x86_64)

This is a fresh install with the command sudo apt-get updates upgrade run and wget installed. Followed this install guide http://download1.parallels.com/Ples...-migration-guide/index.htm?fileName=65780.htm


gtiadmin@WEB01:~$ sudo wget -O - https://autoinstall.plesk.com/one-click-installer | sh
[sudo] password for gtiadmin:
--2015-12-18 13:56:38-- https://autoinstall.plesk.com/one-click-installer
Resolving autoinstall.plesk.com (autoinstall.plesk.com)... 72.21.81.253
Connecting to autoinstall.plesk.com (autoinstall.plesk.com)|72.21.81.253|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 5608 (5.5K) [text/plain]
Saving to: ‘STDOUT’

100%[======================================>] 5,608 --.-K/s in 0s

2015-12-18 13:56:38 (316 MB/s) - written to stdout [5608/5608]

ERROR: You should have superuser privileges to install Plesk
gtiadmin@WEB01:~$

Any ideas? I am stumped :(
 
Back
Top