1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Unable to determine the domain name of my computer

Discussion in 'Plesk for Linux - 8.x and Older' started by g alera, Apr 17, 2006.

  1. g alera

    g alera Guest

    0
     
    Hi everyone,

    I have tried to upgrade from 7.5.4. to 8.0.0 .

    After download the update, nothing has occured and we are still on 7.5.4
    But Qmail service have stopped and I cant restart it in the control panel, getting the follwing error:

    Unable to make action: Unable to manage service by mailmng: mailmng: Service qmail failed to start


    After looking the logs I think the problem may be this:

    --------------------------------------------------------------

    Download file versions.inf3: 22%..100% done
    Download file PSA_8.0.0/plesk-8.0.0-fc1-i386.inf3: 29%..100% done
    Checking for system installed packages...done.
    Check for components installation status
    Reading system installed packages...done.
    Download file plesk-8.0.0-fc1-i386.hdr.gz: 36%..71%..100% done
    Download file plesk-8.0.0-fc1-i386.hdr.gz: 36%..73%..100% done
    Resolve components
    There are some also needed components will installed too: 'autoinstaller'
    Get Plesk product packages.
    Get system update packages.
    Start packages installation
    Install package psa
    Trying to define super-server internet daemon type... xinetd
    Trying to check if xinetd daemon is running... done
    Unable to determine the domain name of your computer.
    Please, run the 'domainname' or 'hostname -f' command
    from the console and make sure that the command returns your domain name.
    
    ERROR while trying to get domain name
    Check the error reason(see log file: /tmp/psa_8.0.0_FedoraCore_1_build80060331.13_upgrade.log), fix and try again

    Aborting...

    error: %pre(psa-8.0.0-fc1.build80060331.13) scriptlet failed, exit status 1
    error: install: %pre scriptlet failed (2), skipping psa-8.0.0-fc1.build80060331.13
    Error while execute command rpm -U /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-1-i386/base/psa-8.0.0-fc1.build80060331.13.i586.rpm
    ERROR: error while executing RPM


    ---
    Plesk autoinstaller.
    --------------------------------------------------------------


    How can I solve this problem? We host 60+ domains and our clients are angry now
    Best regars and thanks in advance,
    Alejandro
     
  2. NightStorm

    NightStorm Guest

    0
     
    And have you done this? Does either command return the name of your server?
     
  3. g alera

    g alera Guest

    0
     
    Yes,

    To the "domainname" command, the answer is:

    "(none)"
     
  4. NightStorm

    NightStorm Guest

    0
     
    And to the hostname -f command?
    One or the other should output an actual server name ("none" does not count).

    If it doesn't, then you will have to set the server name up prior to setting up Plesk.

    http://forum.ev1servers.net/showthread.php?t=20397 will walk you through a quick how-to on setting the hostname for the server. There's even a script to make it easier on you.
     
  5. g alera

    g alera Guest

    0
     
    # hostname -f
    rack-41

    Everything was fine on 7.5.4 but I upgraded because
    drweb didn't work properly. I regret now.

    Any way other than a script?

    Thanks NightStorm
     
  6. NightStorm

    NightStorm Guest

    0
     
    If the error is that it can't get a hostname of your server, then that is what would have to be resolved.
    rack-41 isn't a valid servername anyway. They should be something like server.domain.com with a valid A record pointing from that to your server's primary IP address (some mail servers will reject mail, if it can't get an rdns on the server sending the mail).
    The script is really quite simple. All it does is edit two files, and reconfigure the Plesk settings to match:
    /etc/hosts
    /etc/sysconfig/network
    A step by step explaination of how it works, and what you do can be found at http://www.easyservermanagement.com/howto/hostname.html.
     
  7. kram@

    kram@ Regular Pleskian

    26
    40%
    Joined:
    Dec 11, 2003
    Messages:
    152
    Likes Received:
    2
    Location:
    South Africa
    Had the same issue,

    First edit you /etc/sysconfig/network

    Make sure the hostname is configured there.

    HOSTNAME=your.server.com

    Next check you etc/hosts

    127.0.0.1 your.servername.com localhost

    Make sure the localhost is last
     
Loading...