1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Unable to open logs after raname of error_log of Apache

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by MorrisM, Jan 19, 2011.

  1. MorrisM

    MorrisM Guest

    0
     
    Hi, I hope someone of you can help me solve a (i hope... a little) problem. I was deleting all logs processed in rotation on my server with Plesk Panel 9.0.0 and CentOS 5, in the folder "domain/statistics/logs". By mistake I renamed "error_log" file and now Apache can restart. When in Putty I send the command "service httpd restart", it fails giving me the error "Unable to open logs". I just renamed the error_log file to the original but the problem remain.

    I tried to access to the Plesk Panel, I went on the "Web Hosting Settings" for the specific domain, I unchecked "Custom Error Documents", applied the modidy and re-checked the option: nothing, Apache don't want to restart.

    So, I have a strage situation: Apache is currently running correctly (it seems), but I can't restart it.

    Please, someone can help me solve that problem? I searched in this forum and googled for a solution but... nothing...

    Thank you very much for your support.
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,543
    Likes Received:
    1,238
    Location:
    Novosibirsk, Russia
    For some reasons Apache can't get access to logs. Maybe it is caused by limit for open files. Try 'ulimit -n 2048' at least.
     
  3. MorrisM

    MorrisM Guest

    0
     
    Thank you for your answer, but it don't solve the problem... maybe I have to create the file with the same permissions but i'm not sure how.
     
  4. MorrisM

    MorrisM Guest

    0
     
    i solved... i renamed the error_log with the original name, "pkill httpd", and rested Apache... now it seems to run correctly.

    Anyway, thank you very much for your support.
     
Loading...