• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Unable to set the certificate: Invalid certificate format.

M

MikkyX

Guest
Plesk 7.5.3 on Fedora Core 2 (I know, old box, but it's not ours) - having some trouble installing an SSL certificate.

The domain in question already has an SSL which is about to expire - generated a new CSR via Plesk using the same details that were on the existing certificate. Sent the CSR off to Verisign - few days later, got our certificate back. Copied and pasted it into the relevant box and got this alert and error message showing below the now pink certificate textarea:

"Unable to set the certificate: Invalid certificate format."

Went to the Verisign website to get the intermediate CA Certificate, pasted this in as well - no joy. Google doesn't turn up an awful lot of info about this (one match, also on these forums, problem wasn't solved) so if anyone knows how to fix it, please help - their current certificate expires on Sunday!
 
Anyone? Help! If I don't get it installed today it's going to expire......
 
Panic over (possibly) - turns out our original CSR and request were made as if it was an IIS server - oops! - I've had it reissued for Apache and hopefully that will fix it.....
 
Back
Top