1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Unable to setup Wordpress permalinks to work

Discussion in 'Plesk for Linux - 8.x and Older' started by Steven80, Feb 1, 2011.

  1. Steven80

    Steven80 Guest

    0
     
    Hi,

    I have an outstanding issue that really needs some advice.

    I'm running WordPress website with Parallel Plesks and I cannot seem to get permalinks to work.

    I can only use the default "ugly" URL that is not acceptable for my SEO website.

    I have tried the following remedial action:

    1. Create .htaccess file as instructed in http://codex.wordpress.org/Using_Permalinks

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    2. Ensure that .htaccess file is stored in httpdocs folder.

    3. Ensure that my .htaccess has read, write, execute permissions.

    4. Tried to modify my .htaccess rewrite rules as shown in:
    http://forums.powweb.com/showthread.php?t=66112

    5. I tried to modify wp-includes/vars.php where I replace:

    $is_apache = strstr($_SERVER['SERVER_SOFTWARE'], 'Apache') ? 1 : 0;

    with

    $is_apache = 1;

    6. I tried using this permalink structure as suggested by WordPress

    /index.php/%year%/%monthnum%/%day%/%postname%/

    Nothing works and I am perplexed.

    Any advice or help is very much appreciated.

    Thks!
     
Loading...