• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Update 12.0 to 12.5: IP Addresses gone, ngnix broken

southy

Basic Pleskian
Hi all,

I have a CentOS 6 with a Plesk 12.0 just updated to 12.5. It's a VM on a Proxmox host.
Update went alright until I rebooted to see if it survives. Well: It doesn't.
Of my network interfaces, only lo and localhost came up - my two "real" IP addresses didn't.

e.g.: /etc/sysconfig/network-scripts/ifcfg-venet0:0
DEVICE=venet0:0
ONBOOT=yes
IPADDR=x.x.x.x
NETMASK=255.255.255.255

doesn't come up by itself. When I try
> ifconfig venet0:0 up
I get:
> SIOCSIFFLAGS: Cannot assign requested address

Well, clever me tried manually:
> ifconfig venet0:0 x.x.x.x netmask 255.255.255.255 up
and for whatever strange reason: this works.

Now the problem is: SSH works fine, ping works fine and I can directly address apache on DOMAIN.COM:7080
BUT: NGNIX won't start up:

Unable to make action: Unable to manage service by nginxmng: ('start', 'nginx'). Error: [2015-11-14 22:16:56] ERR [util_exec] proc_close() failed ['/usr/local/psa/admin/bin/nginx_control' '--start'] with exit code [1]
Can not start proxy server: /usr/local/psa/admin/sbin/nginx-config execution failed:
nginx: [emerg] bind() to x.x.x.x:80 failed (99: Cannot assign requested address)
nginx: configuration file /etc/nginx/nginx.conf test failed

Can anyone advise how to reapair NGNIX or why the interfaces won't come up?
Or can anyone please tell me how to undo the complete update as everything (including reboots & interfaces up & down) has been perfectly fine until yesterday?

THANKS!
 
Last edited:
Found the problem:

I had a third IP address defined for use within Plesk; but I did not assign it within the Proxmox host.
This caused the trouble. Solution: remove third address from Plesk IP management.
Done.
ANother test-reboot will have to wait until another backup is finished, but it should work now.
 
Back
Top