1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Update Plesk 7.5.3 -> 7.5.4 on VZPP

Discussion in 'Plesk for Linux - 8.x and Older' started by saemmy, Sep 7, 2005.

  1. saemmy

    saemmy Guest

    0
     
    Is there a guide, to update Plesk 7.5.3 to 7.5.4 on a Virtuozzo DDS?
     
  2. Cranky

    Cranky Guest

    0
     
    It should be done by the node admin with virtuozzo templates.
     
  3. 00Kell

    00Kell Guest

    0
     
    I assume that I should be able to use the Plesk updater to upgrade to 7.5.4 but that option isn't available.

    I have also tried 'yum update' but get this error:

    Gathering header information file(s) from server(s)
    Server: Atomic Rocket Turtle - 9 - Atomic PSA
    retrygrab() failed for:
    http://shinn.net/pub/Linux/atomic/psa/9/headers/header.info
    Executing failover method
    failover: out of servers to try
    Error getting file http://shinn.net/pub/Linux/atomic/psa/9/headers/header.info
    [Errno 4] IOError: HTTP Error 404: Not Found


    Any ideas?
     
  4. Cranky

    Cranky Guest

    0
     
    It's disabled on Plesk for Virtuozzo as your provider should perform the upgrade with templates. If you insist on doing this yourself the RPM upgrade should work fine, but I'd highly recommend your provider does it via templates.
     
  5. 00Kell

    00Kell Guest

    0
     
    Thanks Cranky!
     
  6. AzGilrock

    AzGilrock Guest

    0
     
    I'm also running Plesk on the Virtuozzo version and my provider (Godaddy) doesn't seem to know what their doing. The first thing I wanted to do was backup my system and I'm running into trouble figuring out how to do that because I tried using sysbk and it fails when it gets to the mysql database because apparently the Plesk installation disables the root password. I'm thinking I could manually add it back in but I'm afraid of breaking things I don't understand yet.

    So then I purchased the 4PSA Total Backup but it doesn't seem to run because my Backup Utilities are not installed for Plesk. The Backup button is greyed out. So I call my provider and they led me through using the Updater button which surprised me that it seemed to be working because I had previously read this post that said it wouldn't work under the Vistuozzo version. So they had me check the Backup button and run it. Well I ended up with the following error:

    AutoInstallerManager::getAutoInstaller() failed: AutoInstallerManager::_autoInstallerCall() failed: autoinstaller failed: Auto-installer does not work inside Virtuozzo environment. Refer to your service provider in order to obtain Plesk updates.

    This error is still displayed whenever I hit the Updater button and it's been a week and my provider hasn't fixed it. When I call they mention things like they have a special version of Plesk that was built for them and the Updater is broken in version 7.5.4 and that they should not have had me run the updater because they don't recommend their customers use version 7.5.4. Well I didn't do the upgrade I just followed what they told me over the phone. The updater button apparently upgraded Plesk to 7.5.4 when they were attempting to get me to upgrade the Backup functionality.

    So now they say there is a patch but it wasn't clear whether the patch is out yet or they are waiting for it. They really don't sound like they know what they are doing. It took me two phone calls totalling 1.5 hours to finally convince them that my license was not updated correctly when I paid for the deluxe version of Plesk which added things like Spamassasin and the Application vault.

    Frustrated,
    Gil Jones
     
  7. AzGilrock

    AzGilrock Guest

    0
     
    Well I think I might have to retract my statement about the 4PSA Total Backup not working yet because I just happened to look at it today and it shows three successful backups since Friday. I'm just not sure what exactly is being backup up. Is this backing up my entire server? I don't see any settings for specifying which folders to backup.

    <Update> I found the online manual and it appears that my whole server is being backed up since I selected the tar method. This is assuming the include_path is not set by default. I'll have to check that when I can access my server.

    Gil Jones
     
Loading...