1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Upgrade php to 5.2.4 or higher on Plesk 10.3.1

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by J Cole, Oct 24, 2011.

  1. J Cole

    J Cole Basic Pleskian

    24
    73%
    Joined:
    Feb 26, 2009
    Messages:
    63
    Likes Received:
    0
    Hello, how do i upgrade php on CentOS 5.6 64bits on Plesk 10.3.1

    and on Plesk 9.6 CentOS 32 bits

    Both servers has web sites.

    Thanks
    Jc
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,543
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
  3. figjam

    figjam New Pleskian

    22
    57%
    Joined:
    Mar 28, 2007
    Messages:
    19
    Likes Received:
    0
    Php have been including the following message in all PHP releases since 5.3.6:
    All PHP users should note that the PHP 5.2 series is NOT supported anymore. All users are strongly encouraged to upgrade to PHP 5.3.x

    There is a discussion of most of the issues here: Need urgent help - PHP 5.2 on Plesk 10.3.1

    So if you're ok with going to PHP 5.3 the quick ways are:

    Plesk 10.3.1
    1. Go to: "Server Management" -> "Tools and Utilities" -> "Panel" -> "Updates" and select "Add Components" (the middle one).

    2. Under "Different PHP interpreter versions" select the option "PHP5.3 support"

    3. Select "Continue"


    Plesk 9.5.4
    1. Go to: "Home" -> "Help & Support" -> "Updates" and select "Parallels Plesk Panel 9.5.4"

    2. Select "PHP5.3 support"

    3. Select "Install" on the bar above the components


    Make sure you have a backup of the whole server (not just plesk) that you can revert to. There are all kinds of dependencies involved that can leave you with a major mess if it goes wrong.


    Cheers,


    Andrew
     
  4. J Cole

    J Cole Basic Pleskian

    24
    73%
    Joined:
    Feb 26, 2009
    Messages:
    63
    Likes Received:
    0
    Upgrade PHP

    Hello,

    can any tell me which of the best way to upgrade php

    Use from http://www.atomicorp.com/wiki/index.php/PHP

    or below?

    Plesk 10.3.1
    1. Go to: "Server Management" -> "Tools and Utilities" -> "Panel" -> "Updates" and select "Add Components" (the middle one).

    2. Under "Different PHP interpreter versions" select the option "PHP5.3 support"

    3. Select "Continue"


    Plesk 9.5.4
    1. Go to: "Home" -> "Help & Support" -> "Updates" and select "Parallels Plesk Panel 9.5.4"

    2. Select "PHP5.3 support"

    3. Select "Install" on the bar above the components
     
  5. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,543
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
    Use Plesk method.
     
  6. J Cole

    J Cole Basic Pleskian

    24
    73%
    Joined:
    Feb 26, 2009
    Messages:
    63
    Likes Received:
    0
    Thank you, the Plesk method work on 10.31 I will try the 9.6 later

    Regards
     
  7. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,543
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
    Yes, you can run /usr/local/psa/admin/sbin/autoinstaller for Plesk 9.5.4 version for Centos and select PHP5.3 for installation in menu.
     
  8. J Cole

    J Cole Basic Pleskian

    24
    73%
    Joined:
    Feb 26, 2009
    Messages:
    63
    Likes Received:
    0
    I tryed to upgrade the PHP I got the error below

    File downloading PSA_9.5.4/update-rpm-CentOS-5-i386/php53-xml-5.3.3-1.el5_6.1.i386.rpm: was skipped because of md5 checksum match.
    File downloading PSA_9.5.4/update-rpm-CentOS-5-i386/php53-common-5.3.3-1.el5_6.1.i386.rpm: was skipped because of md5 checksum match.
    Starting installation of packages
    Installing the package psa-migration-manager-9.5.4-cos5.build95110630.11.i586, psa-backup-manager-9.5.4-cos5.build95110630.11.i586, psa-api-rpc-9.5.4-cos5.build95110630.11.noarch, psa-api-9.5.4-cos5.build95110630.11.noarch
    error: Failed dependencies:
    psa < 9.5.4 conflicts with psa-api-9.5.4-cos5.build95110630.11.noarch
    ERROR: Unable to install the requested packages because either there is
    not enough free disk space left, or there are package dependency problems.
    Warning! Not all packages were installed.
    Please check if your system services are operable.
    Please, contact product technical support.
    [root@ns2 ~]#
     
Loading...