• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Upgrade to 10.0.1 - massive failure

Phil Wareham

New Pleskian
I initiated the upgrade from Plesk 9.5.3 to 10.0.1 through the control panel -> updater.
That seemed to be going fine at first but something went horribly wrong, now the control panel and all domains are down on the server. On scouring the forums I found and used the following suggestion to fix it:

# /usr/local/psa/bootstrapper/pp10.9.0-bootstrapper/bootstrapper.sh repair

After a while that failed with the following error message:

WARNING!
During the cannot update db. Please rerun /usr/local/psa/admin/plib/scripts/db-update-plesk10.php manually found some problems
Continue...

Trying to executing mail_restore to synchronize mail server settings and Plesk Database... done
Trying to start service httpd... done
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)

ERROR while trying to execute SQL query, the query was: DELETE FROM BackendCache
Check the error reason(see log file: /tmp/pp10.9.0-bootstrapper.101125.11.34.log), fix and try again


===> Restoring database from backup /var/lib/psa/dumps/mysql.preupgrade.dump.gz


**** Product repair failed.

***** problem report *****
ERROR while trying to execute SQL query, the query was: DELETE FROM BackendCache
Check the error reason(see log file: /tmp/pp10.9.0-bootstrapper.101125.11.34.log), fix and try again

Can someone please help tell me how to resolve this, I have several clients' sites on this server so it's imperative I get this back up and running ASAP.

Thanks,
Phil
 
OK, running...

# /usr/local/psa/bootstrapper/pp10.9.0-bootstrapper/bootstrapper.sh repair

..a second time seems to have resolved the problems. The server appears to be up and functioning normal again. Phew.
 
Back
Top