• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Upgrade to 7.5.3 failed - postgresql dependency

I

independis

Guest
Hi,

I just wanted to upgrade to 7.5.3 with the Plesk Updater but receive a dependency error message:

Preparing for packages installation...Error reading info for conflict check of installed package (null).
Error reading info for conflict check of installed package (null).

----- begin of output -----
Installing heimdal-lib-0.6.1rc3-55.15.i586.rpm
Installing postgresql-libs-7.4.7-0.5.i586.rpm
Installing postgresql-7.4.7-0.5.i586.rpm
error: Failed dependencies:
postgresql = 7.4.6 is needed by (installed) postgresql-server-7.4.6-0.2

----- end of output -----
===> Autoinstaller: stopped logging at Wed Aug 10 15:19:44 2005

***** end of log file *****

It looks like postgresql 7.4.7 is installed and 7.4.6 is needed, but I didn't install anything apart from or without Plesk!

Any idea?

Ralf
 
Execute:

rpm -e postgresql-server

and next time you will start the upgrade process it will install postgresql-server also. Or you can manually update postgresql-server RPM in command line.
 
Back
Top