• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Upgrade to Plesk 12 said: hostname: Unknown host

Azurel

Silver Pleskian
I use "CentOS 6.6 (Final)" with panel version 11.5.30 Update #48 and get this error for upgrade to 12.0:
Parallels Panel pre-upgrade check...
hostname: Unknown host
FATAL_ERROR: Command: hostname -f returns:
Hostname is not defined and configured. Unable to get hostname. Server should have properly configured hostname and it should be resolved locally.

I have in /etc/sysconfig/network:

HOSTNAME="mail"
NETWORKING=yes
NETWORKING_IPV6="yes"
IPV6_DEFAULTDEV="eth0"

I'm a customer from Hosteurope and in HE control panel of server I find:
HOSTNAME = "mail.mydomain.tld"
The same for "Reverse-DNS" in IPv4 and IPv6.

Can anybody tell me what is wrong?
 
Hello Azurel,
You can set the hostname of your server with:
Code:
echo host123.your-domain.com > /etc/hostname
/etc/init.d/hostname.sh start
 
Thanks, but the file /etc/init.d/hostname.sh not exists on my centOS.
/etc/hostname not exists too. I don't think it should create a new empty file?
 
It's OK for /etc/init.d/hostname.sh not to exist on CentOS, however /etc/hostname should exist.
Never the less, you can create it and in it add your host name ..
Code:
vim /etc/hostname

And add the content such as
Code:
host123.your-domain.com

Remember your hostname should resolve to the IP address of that very server.
 
Back
Top