1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Upgraded spamassassin but ...

Discussion in 'Plesk for Linux - 8.x and Older' started by CBiLL, Aug 30, 2005.

  1. CBiLL

    CBiLL Guest

    0
     
    I did a yum ugrade spamassassin and it upgraded it from 2.64 to 3 from ART repo

    but it died or something so I went into Plesk admin control panel and tried to restart it then it just refuse to restart it so I ssh'ed in to see if spam assassin service was still running but it wasn't so I click on Plesk Spamassassin in service and it start up after clicking on it several time.

    No idea why it doing this but I went to config RulesDuJour for spamassassin 3 and when it did a --lint it spill out this errors.

    Lint output: config: SpamAssassin failed to parse line, skipping: rewrite_subject 1
    config: SpamAssassin failed to parse line, skipping: use_terse_report 0
    config: SpamAssassin failed to parse line, skipping: auto_learn 1
    config: SpamAssassin failed to parse line, skipping: subject_tag *****SPAM*****
    lint: 4 issues detected.


    Any idea how to fix this?

    Thank you
    Bill
     
  2. CBiLL

    CBiLL Guest

    0
     
    I went back to spamassassin 2.63 and everything started working again.

    I doubt there a spamassassin 3 support in 7.5.4 and if there is then it's broken.


    Bill
     
  3. crash

    crash Guest

    0
     
  4. CBiLL

    CBiLL Guest

    0
     
    Yes I understood that

    but the thing is Sw-Soft annoucenced that 7.5.4 supports Spamassassin 3.0 now.

    and they did not update thier own psa-spamassassin support to reflect that 3.0 change in rewrite so they should not have annoucnced it as 3.0 being supported in the first place until it can actually work together without any errors.

    So that why i went back to 2.63 for right now. i am sure I can customize the 3.0 to work with it but that would defeat the purpose of having a web management control panel in the first place if you were going to have to go in and customize the application to make it work.


    Hell even with that rewrite error, they should been able to spot the error easy right off the bat so it sorta tell me they didn't even bother testing it before annoucing the 3.0 support.



    Bill
     
  5. cmaxwell

    cmaxwell Regular Pleskian

    25
    73%
    Joined:
    Aug 1, 2001
    Messages:
    150
    Likes Received:
    1
    I agree it was a hasty press release to announce "support" for SpamAssassin 3 when it doesn't work.

    I hope they will bundle proper support for it and offer it in the Updater so that when it says "An update is available" for SpamAssassin, it will update both the psa-spamassassin and spamassassin RPMs seamlessly. But only when it works properly please SWsoft!

    CBill, how did you roll back to version 2.63 safely without losing everyone's spam databases? :rolleyes:

    RHN up2date magically installed spamassassin 3.1 on our RHES3 servers the other night and also left 2.63 installed - I removed 3.1 but it looks as if the "use server-wide spam settings" option is not working properly because only a tiny amount of spam is now being identified compared to before.

    - Chris
     
  6. Jllynch

    Jllynch Regular Pleskian

    28
     
    Joined:
    Nov 11, 2003
    Messages:
    242
    Likes Received:
    0
    Our .spamassassin/user_prefs files now have both the old and new settings in them for both versions;

    required_hits 7
    rewrite_subject 1
    subject_tag *****SPAM*****
    rewrite_header subject *****SPAM*****
    required_score 7



    So the log files are now full of
    config: failed to parse line, skipping: rewrite_subject 1

    etc

    Does anyone have a solution for this?
     
Loading...