1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Upgrading from PHP 5.1.6 -> 5.3 failing

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by Swamper, Feb 6, 2011.

  1. Swamper

    Swamper Guest

    0
     
    I tried upgrading via the control panel to 5.3 but it keeps failing. In case this matters, this is a test box that had 9.3 prior and I went straight to 10.1.1 without incident.

    What do I need to do to get this to work? Thanks.

    Execute command yum -y --enablerepo PSA_10_1_1-dist --enablerepo PSA_10_1_1-thirdparty --enablerepo SITEBUILDER_5_1_0-dist --enablerepo SITEBUILDER_5_1_0-thirdparty --enablerepo PPB_10_1_0-dist --enablerepo PPB_10_1_0-thirdparty install php53-ioncube-loader php53-sqlite2 psa-php53-configurator
    Execute command yum -y --enablerepo PSA_10_1_1-dist --enablerepo PSA_10_1_1-thirdparty --enablerepo SITEBUILDER_5_1_0-dist --enablerepo SITEBUILDER_5_1_0-thirdparty --enablerepo PPB_10_1_0-dist --enablerepo PPB_10_1_0-thirdparty install php53-ioncube-loader php53-sqlite2 psa-php53-configurator
    Loaded plugins: rhnplugin, security
    Excluding Packages in global exclude list
    Finished
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package php53-ioncube-loader.i386 0:3.3.20-11011816 set to be updated
    --> Processing Dependency: php53 < 5.4.0 for package: php53-ioncube-loader
    --> Processing Dependency: php53 >= 5.3.0 for package: php53-ioncube-loader
    ---> Package php53-sqlite2.i386 0:5.3.2-11011810 set to be updated
    ---> Package psa-php53-configurator.noarch 0:1.6.1-rhel5.build1010110118.12 set to be updated
    --> Processing Dependency: php53-mysql for package: psa-php53-configurator
    --> Processing Dependency: php53-imap for package: psa-php53-configurator
    --> Processing Dependency: php53-cli for package: psa-php53-configurator
    --> Processing Dependency: php53-pdo for package: psa-php53-configurator
    --> Processing Dependency: php53-mbstring for package: psa-php53-configurator
    --> Processing Dependency: php53-xml for package: psa-php53-configurator
    --> Processing Dependency: php53-gd for package: psa-php53-configurator
    --> Running transaction check
    ---> Package php53.i386 0:5.3.3-1.el5 set to be updated
    --> Processing Dependency: php53-common = 5.3.3-1.el5 for package: php53
    ---> Package php53-cli.i386 0:5.3.3-1.el5 set to be updated
    ---> Package php53-gd.i386 0:5.3.3-1.el5 set to be updated
    ---> Package php53-imap.i386 0:5.3.3-1.el5 set to be updated
    ---> Package php53-mbstring.i386 0:5.3.3-1.el5 set to be updated
    ---> Package php53-mysql.i386 0:5.3.3-1.el5 set to be updated
    ---> Package php53-pdo.i386 0:5.3.3-1.el5 set to be updated
    ---> Package php53-xml.i386 0:5.3.3-1.el5 set to be updated
    --> Running transaction check
    ---> Package php53-common.i386 0:5.3.3-1.el5 set to be updated
    Loaded plugins: rhnplugin, security
    Excluding Packages in global exclude list
    Finished
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package php53-ioncube-loader.i386 0:3.3.20-11011816 set to be updated
    --> Processing Dependency: php53 < 5.4.0 for package: php53-ioncube-loader
    --> Processing Dependency: php53 >= 5.3.0 for package: php53-ioncube-loader
    ---> Package php53-sqlite2.i386 0:5.3.2-11011810 set to be updated
    ---> Package psa-php53-configurator.noarch 0:1.6.1-rhel5.build1010110118.12 set to be updated
    --> Processing Dependency: php53-mysql for package: psa-php53-configurator
    --> Processing Dependency: php53-imap for package: psa-php53-configurator
    --> Processing Dependency: php53-cli for package: psa-php53-configurator
    --> Processing Dependency: php53-pdo for package: psa-php53-configurator
    --> Processing Dependency: php53-mbstring for package: psa-php53-configurator
    --> Processing Dependency: php53-xml for package: psa-php53-configurator
    --> Processing Dependency: php53-gd for package: psa-php53-configurator
    --> Running transaction check
    ---> Package php53.i386 0:5.3.3-1.el5 set to be updated
    --> Processing Dependency: php53-common = 5.3.3-1.el5 for package: php53
    ---> Package php53-cli.i386 0:5.3.3-1.el5 set to be updated
    ---> Package php53-gd.i386 0:5.3.3-1.el5 set to be updated
    ---> Package php53-imap.i386 0:5.3.3-1.el5 set to be updated
    ---> Package php53-mbstring.i386 0:5.3.3-1.el5 set to be updated
    ---> Package php53-mysql.i386 0:5.3.3-1.el5 set to be updated
    ---> Package php53-pdo.i386 0:5.3.3-1.el5 set to be updated
    ---> Package php53-xml.i386 0:5.3.3-1.el5 set to be updated
    --> Running transaction check
    ---> Package php53-common.i386 0:5.3.3-1.el5 set to be updated
    --> Processing Conflict: php53-common conflicts php-common
    --> Finished Dependency Resolution
    php53-common-5.3.3-1.el5.i386 from rhel-i386-server-5 has depsolving problems
    --> php53-common conflicts with php-common
    Error: php53-common conflicts with php-common
    You could try using --skip-broken to work around the problem
    You could try running: package-cleanup --problems
    package-cleanup --dupes
    rpm -Va --nofiles --nodigest
    The program package-cleanup is found in the yum-utils package.
    Execute command /usr/sbin/getenforce
    --> Processing Conflict: php53-common conflicts php-common
    --> Finished Dependency Resolution
    php53-common-5.3.3-1.el5.i386 from rhel-i386-server-5 has depsolving problems
    --> php53-common conflicts with php-common
    Error: php53-common conflicts with php-common
    You could try using --skip-broken to work around the problem
    You could try running: package-cleanup --problems
    package-cleanup --dupes
    rpm -Va --nofiles --nodigest

    The program package-cleanup is found in the yum-utils package.
    Execute command /usr/sbin/getenforce
    Disabled
    Error: The Yum utility failed to install the required packages.
    Attention! Your software might be inoperable.
    Please, contact product technical support.


    [root@ tmp]# rpm -qa | grep -i php
    php-xml-5.1.6-23.el5
    php-gd-5.1.6-23.el5
    php-common-5.1.6-23.el5
    php-imap-5.1.6-23.el5
    php-mysql-5.1.6-23.el5
    psa-php5-configurator-1.6.1-rhel5.build1010110131.16
    php-cli-5.1.6-23.el5
    php-mbstring-5.1.6-23.el5
    php-5.1.6-23.el5
    php-pdo-5.1.6-23.el5
     
  2. Swamper

    Swamper Guest

    0
     
    yum erase php php-common php-cli
    (this removed PHP 5.1.6 and all dependencies (Plesk/etc.))

    Ran autoconfigure from shell and selected PHP53 to be installed.

    Seems to be running normally.
     
  3. ryan_turner

    ryan_turner Guest

    0
     
    I had the same problem. I don't know how to run plesk 10's auto configure script, so I didn't try your fix. Waiting on instruction... running RHEL 64 bit, Plesk 10.1.1 that's about 30 minutes old; just migrated all of my accounts and then ran into this issue after trying to switch to PHP 5.3 in the product installer. Now, plesk is broken. Great.

     
    Last edited by a moderator: Mar 20, 2011
  4. MatthewTLS

    MatthewTLS Guest

    0
     
    I had a similar issue with upgrading my PHP to 5.3. I had to manually remove the PHP packages:

    php-pdo-5.2.10-1.el5.centos
    php-ldap-5.2.10-1.el5.centos
    php-gd-5.2.10-1.el5.centos
    php-common-5.2.10-1.el5.centos
    php-cli-5.2.10-1.el5.centos
    php-imap-5.2.10-1.el5.centos
    php-mysql-5.2.10-1.el5.centos
    php-xml-5.2.10-1.el5.centos
    php-5.2.10-1.el5.centos
    php-mbstring-5.2.10-1.el5.centos

    And install the "php53" packages:

    php53-mysql-5.3.3-1.el5
    php53-gd-5.3.3-1.el5
    php53-common-5.3.3-1.el5
    php53-pdo-5.3.3-1.el5
    php53-xml-5.3.3-1.el5
    php53-imap-5.3.3-1.el5
    php53-5.3.3-1.el5

    The problem is, Plesk simply queries the RPM database for the package "php". RedHat is now packaging PHP 5.3 as "php53", not just "php". So, to make Plesk play happy with PHP 5.3, I had to create a blank RPM and install it:

    php-5.3.3-1

    I hope this helps!
     
  5. nalawong

    nalawong Guest

    0
     
    Hi Matthew,

    I've been trying this out for the past 1-2 weeks!
    May I know how do you create a blank RPM?
     
  6. MatthewTLS

    MatthewTLS Guest

    0
     
    You will want to create your RPM using an under-privileged account (i.e. not root).

    First, as root:

    Then as your under-privileged account:

    Then create a ~/.rpmmacros file and include the following information:

    Then create tarball and put a README file in it:

    Now create the php.spec file

    Put the following text in your php.spec file:

    Then build the RPM:

    Then, as root:

    Stop and Restart Plesk:

    Login to your admin panel and click on Settings then Server Components. You should see next to php the version number: 5.3.3-1

    Cheers,

    Matthew
     
  7. nalawong

    nalawong Guest

    0
     
    Hi Matthew,

    thanks! I'll try this out!
     
  8. MatthewTLS

    MatthewTLS Guest

    0
     
    Also, make sure when you remove your php packages prior to installing php53 packages you use the --nodeps option. For example:

    This will prevent RPM from complaining about dependencies.

    Cheers!
     
  9. nalawong

    nalawong Guest

    0
     
    Hi Matthew,

    would you be able to give an example in command line, how to you remove this?

    php-pdo-5.2.10-1.el5.centos
    is it?

    yum remove php-pdo-5.2.10-1.el5.centos --nodeps
     
  10. MatthewTLS

    MatthewTLS Guest

    0
     
    rpm -e --nodeps php-pdo
     
  11. nalawong

    nalawong Guest

    0
     
    It worked! I didn't create a blank RPM.
    After removing the the previous php, i typed,

    yum install php53*

    Thank you so much!
     
  12. nalawong

    nalawong Guest

    0
     
    Hello Matthew,

    Nevertheless, I've followed your instructions.
    Created my RPM using an under-privileged account.

    I'm having this prompt on my plesk 10.1 panel.

    Error: New files of configuration for Apache web server were not built due to errors in configuration templates. The detailed error message was e-mailed to you, so please check the e-mail, fix the errors, and click here to retry generating configuration.

    Would you have any idea why?
     
  13. nalawong

    nalawong Guest

    0
     
    Now I've got a new error,
    after creating a new domain name, I'm prompted,

    Error: No secure shell available
     
  14. MatthewTLS

    MatthewTLS Guest

    0
     
    Hmm ... honestly, I'm not sure about either issue. I can only think that it would report "No secure shell available" if you removed the SSHTerm package. It could be related to your previous post:

    I never recommend installing packages by using and asterisk ... funny things can happen. I always explicitly state what packages I want yum or rpm to install for me.

    As for Plesk giving you the error:

    It could be because you installed the blank PHP package. Did something stop working even though you reported that everything was working after installing php53 via yum?
     
  15. nalawong

    nalawong Guest

    0
     
    Sigh... I reported too early. Guess I've got to re-try everything again. this time without the asterisk.
    Thanks for replying! :)
     
  16. nalawong

    nalawong Guest

    0
     
    Hello!

    Parallels have helped me solve the issue.
    below is the their reply.

    Issue caused because psa got corrupted, so we repaired the psa.
    I repaired the psa by following command.
    "/usr/local/psa/bootstrapper/pp10.10.1-bootstrapper/bootstrapper.sh repair".
     
  17. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
  18. jiphex

    jiphex Guest

    0
     
    My only problem with your Atomic RPMs is that I believe the PHP 5.3 ones necessitate an update to MySQL 5.1, which is a step that a lot of our customers are wary of due to the 5.0->5.1 shift requiring a change in the data file format.

    The same thing happened when the 5.2 RPMs first hit the Atomic repo which also required this update. I believe this was fixed though?

    On a server currently with the Atomic PHP 5.2 (and mysql-server-5.0.77-4.el5_5.3) - trying to run "yum update php" (which takes us to 5.3) shows the conflicts at http://pastie.org/1767961
     
  19. SilasO

    SilasO Guest

    0
     
    Am getting "Missing Dependency: php-common = 5.2.17-1.el5.art is needed by package ..." for most packages
    Any suggestion?
    Thanks in advance...
     
  20. SilasO

    SilasO Guest

    0
     
    Solved!.....
     
Loading...