1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

URGENT Re-Activating Domain

Discussion in 'Plesk for Linux - 8.x and Older' started by MrBafner, Jul 30, 2005.

  1. MrBafner

    MrBafner Guest

    0
     
    Had a domain name expire and cannot enable it again. Get the following error message

    "Unable to activate/deactiate domain: domainmng failed: Empty error message from utility."


    Need help pretty quick if possible. Is one other of these in the forum, but only got lead to Plesk support.


    What error message should I delete, from what utility?
     
  2. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Looks like it's not a very common problem, there were at least 3 posts same or similar.

    Did you use the control panel to change the validity period of the domain (Domains - select the domain - Limits - Change date or set for unlimited) before trying to reactivate it? (sounds silly, but the simple things are easy to overlook)


    It may be due to database corruption. Do you have phpMyAdmin installed on the server? With that you could browse the psa database tables and see if there were any inconsistencies with that domain.
     
  3. MrBafner

    MrBafner Guest

    0
     
    Hey, Thanks for the reply.....

    Sure did, reset the validity of the domain name in both the domain name and the hosting. Both are showing 2006, but the domain wont enable without receiving that error.
     
  4. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Do you have phpMyAdmin installed on the server? With that you could browse the psa database tables and see if there were any inconsistencies with that domain
     
  5. MrBafner

    MrBafner Guest

    0
     
    I sure do have phpMyAdmin installed, and yes I am looking for any inconsistancies but with no luck as yet :(
     
  6. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Manually edit the 'domains' table, change the 'status' for that domain to '0', and verify the expiry date. Also make sure 'dns_zone' is TRUE
     
  7. MrBafner

    MrBafner Guest

    0
     
    *GULP*


    *cough*


    now I'm scared


    How would I do that?
     
  8. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Once you select the 'psa' database, then select the 'domains' table.

    Next find the tab 'browse', click this and it will show you the rows (one per domain).

    On the left side there will be an icon looking like a pencil. Click this for the domain in question.

    Change only the expiry date (verify 2006), status (0), and if needed, the dns_zone (true)

    Then click 'Go' button at the bottom to save.
     
  9. MrBafner

    MrBafner Guest

    0
     
    OK... I cannot access anything in the phpMyAdmin for that domain. I have had a look at others and all seems to be OK.

    But the error says "Cannot Connect"

    Because the domain is down I suppose :(
     
  10. MrBafner

    MrBafner Guest

    0
     
    Is there anyway I can do this from root?

    I have Putty installed
     
  11. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Are you the admin of the server, or a client/domain owner?

    If you are the admin, then you should be able to access all domain records whether it is disabled or not.
     
  12. MrBafner

    MrBafner Guest

    0
     
    Yes, I am the admin of the server.

    I see the list of domains, only 25 of them, click on the domain name in question... go to that domain.... click on Databases.... click on 1 of the databases... and go to DbManage.

    A new window pops up saying... can't connect to database.

    I have managed to get into 1 database. But cannot see anything on the server, only that database.
     
  13. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Ummm, I said to table 'domains' then click on Browse, not DbManage

    Unless your version of phpMyAdmin is way different than mine, once you click on the table 'domains', the right side of the screen should have some tabs across the top, the second one says 'Browse'
     
  14. MrBafner

    MrBafner Guest

    0
     
    This is all my component info


    psa 7.5.3-fc1.build75050506.13
    httpd 2.0.50-1.0
    bind 9.2.2.P3-9
    courier-imap 3.0.8-fc1.build75050506.13
    frontpage 5.0.2.2634
    mailman 2.1.5-6
    mysql 3.23.58-4
    postgresql-server 7.3.4-11
    webalizer 2.01_10-14
    php 4.3.8-1.1
    mod_python 3.0.4-0.1
    coldfusion Component was not installed
    psa-migration-manager 7.5.3-fc1.build75050506.18
    SSHTerm 0.2.2-fc1.build75050506.13
    spamassassin 2.63-0.2
    psa-qmail 1.03-fc1.build75050506.13
    psa-qmail-rblsmtpd 0.70-fc1.build75050506.13
    psa-proftpd 1.2.10-fc1.build75050506.13
    psa-logrotate 3.7-fc1.build75050506.13
    psa-spamassassin 7.5.3-fc1.build75050506.13
    tomcat4 4.1.24-full.2jpp
    psa-tomcat-configurator 7.5.3-fc1.build75050506.13
    mod_perl 1.99_12-2
    perl-Apache-ASP 2.57-fc1.build75050506.13
    drweb 4.32.2-rh7_psa
    drweb-qmail 4.32-fc1.build75050506.13
    psa-bu 7.5.3-fc1.build75050506.13
    psa-api-rpc 7.5.3-fc1.build75050602.16

    The only way I can access anything in phpMyAdmin is through the 'database' button under each domain name.

    I can only access each database seperately, unless I am totally missing something.

    I'll take some sceenshots of my Plesk control panel.... may make it a little easier to see.

    If I click on 'Domains' .... I can see 'Tools' - Add New Domain, Domain Templates, Summary Report, Traffic. Then 'Domains' - full list domain names

    Domains

    Then click on the domain name to get

    Domain Name

    Then click on the database button (to access phpMyadmin)

    Database Screenshot

    Then click on the link itself to the database.. and open phpMyAdmin

    Then click on the database button (to access phpMyadmin)

    phpMyAdmin Screenshot


    hope this explains something... maybe not, but cannot access any domain tables
     
  15. jamesyeeoc

    jamesyeeoc Guest

    0
     
    That's what I was just wondering...

    You have been using the control panel version, not a separate installation.

    The control panel version will not allow you access to the 'psa' database.

    I was referring to downloading the phpMyAdmin RPM package and installing it separate from the Plesk control panel.

    There are mysql commandline ways of doing it, but I really s*ck at the command line mysql commands, that's why I use the standalone phpMyAdmin.
     
  16. MrBafner

    MrBafner Guest

    0
     
    I see :(

    I suppose I can use putty to do the command line way... if that helps.

    But I don't think I can access phpMyAdmin directly from the linux box.
     
  17. jamesyeeoc

    jamesyeeoc Guest

    0
     
    From the PuTTY command line (logged in as root, or su root), go into mysql:

    THIS SHOULD WORK FOR PLESK 7.5.3

    mysql -uadmin -pyourpassword psa

    You will then get a prompt:

    mysql>

    at which you type the following:

    UPDATE domains SET cr_date='2006-08-01' WHERE name='domain.com' LIMIT 1;
    (change domain.com to the name of the domain which is expired)

    This should force the date to be changed to what you specify. YYYY-MM-DD format


    UPDATE domains SET status='0' WHERE name='domain.com' LIMIT 1;
    (change domain.com to the name of the domain which is expired)

    This should change the status to active.

    Restart apache from the control panel.
     
  18. MrBafner

    MrBafner Guest

    0
     
    YOU ARE THE MAN!!!!!

    That worked perfectly, domain in the plesk panel is active, running and away.

    The site is still not coming up... but that is probably the domain will need to propogate with the DNS again.

    But whoot... that worked ... YIPPEE YIPPEE YIPPEE

    Thanks heaps for the help, it is appreciated for sure... very much so. I may just get some sleep now. :)
     
  19. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Actually, there should be no propagation since this was an existing domain.

    Check in the control panel to make sure the DNS is turned on for the domain.

    There are 2 database fields for the domain which may also need to be tweaked.
     
  20. MrBafner

    MrBafner Guest

    0
     
    oh :(

    Yes the DNS is showing to be Enabled... so I guess it is working.
     
Loading...