1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

user email password

Discussion in 'Plesk for Linux - 8.x and Older' started by noeaw, Jan 8, 2008.

  1. noeaw

    noeaw Guest

    0
     
    I have recently upgraded to 8.3 (not sure if that is the problem) but now - no combination of letters/numbers is accepted when setting up new email account. Any ideas would be greatly appreciated.

    Thanks
    Anthony
     
  2. Amin Taheri

    Amin Taheri Golden Pleskian Plesk Certified Professional

    33
     
    Joined:
    Jul 5, 2007
    Messages:
    1,398
    Likes Received:
    1
    Location:
    Seattle Area
    Check plesk error logs to see why
     
  3. noeaw

    noeaw Guest

    0
     
    How do you do that?
     
  4. Amin Taheri

    Amin Taheri Golden Pleskian Plesk Certified Professional

    33
     
    Joined:
    Jul 5, 2007
    Messages:
    1,398
    Likes Received:
    1
    Location:
    Seattle Area
    I dont know anything about your system, and if you dont either then hopefully this will be a quick tutorial.


    Find out where the file containing your plesk settings is - this contains all the directories where stuff is

    Code:
    locate psa.conf
    
    This is usally /etc/psa/psa.conf

    Then find out where your product root is ( often refered to as PRODUCT_ROOT_D - and named such in the config file)
    Code:
    grep 'PRODUCT_ROOT_D' /etc/psa/psa.conf
    PRODUCT_ROOT_D /usr/local/psa
    
    usually /usr/local/psa

    Then go into there, and find the logs directory under admin
    /usr/local/psa/admin/logs/

    Then look through those logs - probably the error logs would help more, but any of them could be of assistance depending on your problem.

    if you get real familiar with your config files it will definately help you when things go sour.
     
  5. noeaw

    noeaw Guest

    0
     
    Thanks - that got me to the logs - however - and am way too ignorant to know what to look for. Any idea?
     
  6. Amin Taheri

    Amin Taheri Golden Pleskian Plesk Certified Professional

    33
     
    Joined:
    Jul 5, 2007
    Messages:
    1,398
    Likes Received:
    1
    Location:
    Seattle Area
    Try this:

    Code:
    tail -f /usr/local/psa/admin/logs/httpsd_error_log
    
    This will give you a real time read out of the log file, and will not give you back a prompt. Remember where the log file ended at, and then try your email thing again. Thencome back to that screen and see if anything got logged to the screen.

    If it did, and its not another user (if you have a busy panel this may give you false positives) then you can get a start on it there.
     
  7. noeaw

    noeaw Guest

    0
     
    thanks - when i try entering a new user - I get this
    and i get the following error via control panel:
    Error: Unable to update the mail account properties:
    The password is incorrect, use at least 5 characters. The password should not contain mail account name as its part.
    Only Latin characters, no dictionary words (optional).

    put when I enter no password - the control panel excepts it and the following happens via log:
     
  8. dash

    dash Regular Pleskian Staff Member

    28
    40%
    Joined:
    Sep 26, 2007
    Messages:
    204
    Likes Received:
    47
    Do you have "Check the passwords for mailboxes in the dictionary" and(or) "Use of short (webmaster) and full (webmaster@domain.com) POP3/IMAP mail account names is allowed" options turned on? (on Server->Mail page)

    If yes, try to play with it.
     
  9. noeaw

    noeaw Guest

    0
     
    i tried toggleing the password/dictionary option and then I started getting a error/popup "unable to allow the use of short mail account names for POP3/IMAP accounts. There are mail accounts matching the encrypted passwords" without toggling the short/full option and I cannot set it back to short. Obviously all email account accessing with short name are not working. Any Ideas?
     
  10. Hedgren

    Hedgren Guest

    0
     
    Such problem happens when the password of one of two/several identical mail accounts is stored in Plesk database in encrypted view. As it is encrypted, Plesk cannot compare passwords and make sure that passwords are NOT identical. That is why Plesk does not allow to switch back from 'full' to 'short' mode and does not accept any password if you have 'short' mode set.

    The solutions are:
    - either continue 'full' mode usage
    - or find encrypted passwords and change them through Plesk GUI (they will be saved in plain-text view in Plesk base). For example, to get the list of mail accounts and their passwords, you can use the following command:
    # mysql -uadmin -p`cat /etc/psa/.psa.shadow` -Dpsa -e"select m.mail_name, d.name, a.type, a.password from domains d, mail m, accounts a where m.dom_id = d.id and m.account_id = a.id"
     
Loading...