1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

/var/qmail/control/virtualdomains file corrupt?

Discussion in 'Plesk for Linux - 8.x and Older' started by soarchrist, Oct 22, 2008.

  1. soarchrist

    soarchrist Guest

    0
     
    I added two email addresses to a specific domain and it looks like plesk created a second entry for one domain in the /var/qmail/control/virtualdomains file. When anyone tried to send an email to one of the addresses for that domain, it was rejected because of the faulty duplicate entry. Once I removed the entry, everything works again. What gives, why would plesk do this?

    Now whenever I create a new email address, it breaks for that domain. Do the rcpthosts and virtualhosts files go in order together-- my files have the domains in separate order.

    Anyone? Any help appreciated.
     
  2. soarchrist

    soarchrist Guest

    0
     
    Update.... it doesn't have to do with the virtualdomains file alone. I tested adding an email address on another domain and while it didn't create the duplicate entry, the mail doesn't work!

    So, in short, whenever I add a new email in Plesk, all emails for that domain stop working for incoming mail. They can send fine, but any email going to it gets rejected with this:

    Hi. This is the qmail-send program at mail.soarchrist.com.
    I'm afraid I wasn't able to deliver your message to the following addresses.
    This is a permanent error; I've given up. Sorry it didn't work out.

    <test@soarchrist.com>:
    This address no longer accepts mail.


    Sometimes restarting qmail works... sometimes it doesn't.
     
  3. wsani

    wsani Silver Pleskian

    28
    40%
    Joined:
    Mar 4, 2005
    Messages:
    509
    Likes Received:
    0
  4. soarchrist

    soarchrist Guest

    0
     
    Your suggestion was just what I needed. I ran it with the '--without-spam' option and everything is working perfectly.

    Thanks wsani, I really appreicate you taking the time!

    S.
     
Loading...