• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

/var/qmail/control/virtualdomains file corrupt?

S

soarchrist

Guest
I added two email addresses to a specific domain and it looks like plesk created a second entry for one domain in the /var/qmail/control/virtualdomains file. When anyone tried to send an email to one of the addresses for that domain, it was rejected because of the faulty duplicate entry. Once I removed the entry, everything works again. What gives, why would plesk do this?

Now whenever I create a new email address, it breaks for that domain. Do the rcpthosts and virtualhosts files go in order together-- my files have the domains in separate order.

Anyone? Any help appreciated.
 
Update.... it doesn't have to do with the virtualdomains file alone. I tested adding an email address on another domain and while it didn't create the duplicate entry, the mail doesn't work!

So, in short, whenever I add a new email in Plesk, all emails for that domain stop working for incoming mail. They can send fine, but any email going to it gets rejected with this:

Hi. This is the qmail-send program at mail.soarchrist.com.
I'm afraid I wasn't able to deliver your message to the following addresses.
This is a permanent error; I've given up. Sorry it didn't work out.

<[email protected]>:
This address no longer accepts mail.


Sometimes restarting qmail works... sometimes it doesn't.
 
Your suggestion was just what I needed. I ran it with the '--without-spam' option and everything is working perfectly.

Thanks wsani, I really appreicate you taking the time!

S.
 
Back
Top