1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Websites not showing up

Discussion in 'Plesk for Linux - 8.x and Older' started by new2linux, Mar 25, 2005.

  1. new2linux

    new2linux Guest

    0
     
    I uploaded a website to the httpdocs folder provided by Plesk, yet the page that comes up seems to be the noindex.html page in the /var/www/error folder. I am using RedHat 9.0 OS. Prior to installing Plesk reloaded 7.5, the webpage served up just fine. Any suggestions?
     
  2. Cranky

    Cranky Guest

    0
     
    Is the file called index.html? It needs to be called one of the filenames in /etc/httpd/conf/httpd.conf "DirectoryIndex" list.
     
  3. new2linux

    new2linux Guest

    0
     
    yes, I replaced the placemark index file with the website index file.
     
  4. Cranky

    Cranky Guest

    0
     
    Could you see the placeholder before then?
     
  5. Kevlar3D

    Kevlar3D Guest

    0
     
    have you restarted apache since you created the domain?
     
  6. new2linux

    new2linux Guest

    0
     
    I could see the placeholder prior to this, yes....and yes, I rebooted the server....
     
  7. Kevlar3D

    Kevlar3D Guest

    0
     
    yeah, the problem is what cranky said.
    you can override this setting by creating a text file in the root of your httpdocs called ".htaccess"
    it should say:

    DirectoryIndex index.html

    your server is working, and site loads when you go to the index file directly
    http://www.acrescorp.com/index.html

    note, you dont need to reboot the server, simply starting and stopping or restarting the apache service should be sufficient

    here is some help on .htaccess files if you need it
    http://www.twsc.co.za/htaccess.php
     
  8. new2linux

    new2linux Guest

    0
     
    I went into /etc/httpd/conf/httpd.conf and found the following at the end:

    <Directory "/">
    Options FollowSymLinks

    AllowOverride None

    </Directory>

    #<Directory "/var/www/html">
    <Directory "/home/httpd/vhosts">
    Options Indexes Includes FollowSymLinks

    AllowOverride None
    Allow from all

    Order allow,deny
    </Directory>

    <Directory "/var/www/icons">
    Options Indexes MultiViews

    AllowOverride None
    Allow from all

    Order allow,deny
    </Directory>

    <Directory "/var/www/cgi-bin">
    Options ExecCGI

    AllowOverride None
    Allow from all

    Order allow,deny
    </Directory>

    LoadModule suexec_module modules/mod_suexec.so

    Include /etc/httpd/conf/httpd.include
    AddType text/html .shtml


    Where do I make the changes??
     
  9. new2linux

    new2linux Guest

    0
     
    nevermind...I figured it out...you guys rock!! thanks...
     
Loading...