• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Issue WordPress cloning attempt fails with 'mysqlcheck: Got error: 1045'

Steg

New Pleskian
Server operating system version
Ubuntu 22.04
Plesk version and microupdate number
Obsidian 18.0.50.2
I'm trying to clone a site into a new subdomain and am getting the following error:

Code:
mysqlcheck: Got error: 1045: Access denied for user 'xxxx'@'localhost' (using password: YES) when trying to connect

I wasn't able to locate any threads or KB articles on this. Anyone got any ideas?
 
I could not find anything specific on this situation, but recently there have been some threads that discussed issues when "skip-name-resolve" in /etc/my.cnf was on, because in that case "localhost" cannot be resolved to "127.0.0.1", and if the necessary permission sets in the "user" table of the database are missing for "localhost" as a name, but only refer to "127.0.0.1", access will be denied. You can test if it works by setting "skip-name-resolve = 0" and restarting the database afterwards. If it works, fine, if it does not work, revert to the previous setting.
 
Looks like the main file is actually in /etc/mysql/. However, I don't see skip-name-resolve in any of the .conf files.
 
Could you please add skip_name_resolve = off to my.cnf and restart the database? Does the issue persist?
 
Anyone got another theory?

Would it be easier if I had the client submitted an official support ticket?
 
Yes, please. It has something to do with permissions, but if it is not the host name resolution, it needs to be checked on the server what it is.
 
Back
Top