• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

WP-Toolkit: When proc_open, proc_close are disabled in PHP config, removing plugins fails

Bitpalast

Plesk addicted!
Plesk Guru
TITLE:
WP-Toolkit: When proc_open, proc_close are disabled in PHP config, removing plugins fails
PRODUCT, VERSION, OPERATING SYSTEM, ARCHITECTURE:
Onyx 17.8, latest patches
CentOS 7.6 latest patches
latest WP toolkit
PROBLEM DESCRIPTION:
WP toolkit: When in the subscription the proc_open and proc_close PHP commands are disabled, it is not possible to uninstall plugins.​
STEPS TO REPRODUCE:
Disallow proc_open, proc_close in PHP commands of subscription. Then try to uninstall any plugin in WP toolkit.​
ACTUAL RESULT:
Fails with error message that proc_open/_close are required.​
EXPECTED RESULT:
Should not care about customer account settings, but deinstall plugins anyway.​
ANY ADDITIONAL INFORMATION:
YOUR EXPECTATIONS FROM PLESK SERVICE TEAM:
Confirm bug
 
Thanks, Peter.
This issue has been fixed as part of the bugreport EXTWPTOOLK-2738 and will appear in the near release.
 
Back
Top