1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

WWW prefix problem

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by Le-MinhP, Mar 25, 2012.

  1. Le-MinhP

    Le-MinhP Guest

    0
     
    I don't exactly know how to shortly summarize this problem, so forgive me if the Title is too generic.

    I have a managed server (Ubuntu 10.04 LTS + Plesk 10.4.4) were I host 3 domains. The Domain madgyver.de were you can find my homepage, can now only be reached if you add the www preifx to it.
    EDIT:
    To clarify, if I type www.madgyver.de, everything works fine. If I try madgyver.de, a plesk default page shows up.

    This problem occured right after the renewal date expired (I set it to in unlimited for now). Also at around the same time we upgraded plesk from 10.0 to 10.4.4 to get rid of some security risks which were being systematically exploited.

    What wonders me is that the other domains don't suffer from this.

    Also if you try to reach the index.php (i.e. madgyver.de/index.php) it works fine, preifx or no prefix. Is this to be expected?

    Does anyonw now how to fix this?
     
    Last edited by a moderator: Mar 25, 2012
  2. AntonLS

    AntonLS Basic Pleskian Staff Member

    14
     
    Joined:
    Dec 26, 2011
    Messages:
    33
    Likes Received:
    0
    Just checked www.madgyver.de and madgyver.de and both work fine.
    Both URLs redirect to "http://madgyver.de/index.php?de_home".
    If you still have this issue, try to refresh browser cache.
    Also, try to request http headers by curl:
    curl -I http://madgyver.de/
    curl -I http://www.madgyver.de/
    and provide output.
    (you will need to install curl first)
     
  3. Le-MinhP

    Le-MinhP Guest

    0
     
    Oh man I feel stupid. Tried to "fix" this for 2 days. Should haved tried that first.

    Thanks man
     
Loading...