• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Zend_Controller_Exception: Permission denied when trying to restore backup

System
12.0.18 CentOS 6 1200150126.15
micro update - 48

trying to restore a backup from a different plesk 12 server but it keeps giving me this error

Internal error.
ERROR: Zend_Controller_Exception: Permission denied.#0 /usr/local/psa/admin/plib/CommonPanel/Controller/Action/Abstract.php(191): CommonPanel_Controller_Action_Abstract->_checkForgeryProtectionToken()
#1 /usr/local/psa/admin/externals/Zend/Controller/Action.php(502): CommonPanel_Controller_Action_Abstract->preDispatch()
#2 /usr/local/psa/admin/externals/Zend/Controller/Dispatcher/Standard.php(295): Zend_Controller_Action->dispatch('errorAction')
#3 /usr/local/psa/admin/externals/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
#4 /usr/local/psa/admin/plib/Application/Web.php(38): Zend_Controller_Front->dispatch(NULL)
#5 /usr/local/psa/admin/htdocs/application.php(15): Plesk\Application_Web->run()
#6 {main} (Broker.php:336)

I have tried the solution here http://kb.odin.com/en/122077
but it hasn't fixed my problem
The backup was saved on a personal ftp repository
could that be the issue ?
 

Attachments

  • serverError.jpg
    serverError.jpg
    197.3 KB · Views: 3
Please check your SELinux mode ( it should either be in the mode "Disabled" or "Permissive" ) :


How to switch SELinux to Permissive mode:

setenforce 0
getenforce
=> Permissive
Please retry your previous commands and check if the problem still exists after you changed the SELinux mode.
If it still exists, please try to disable SELinux completely - just to check if this might be the cause.
 
I already set selinux to disabled in the /etc/sysconfig/selinux file
ran the command above and it returns disabled
getenforce
Disabled
this has got me stump? must be missing something
 
Back
Top