1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

"0upgrade: integer expression expected" on upgrade from 10.4.4 to 11.0.9

Discussion in 'Plesk 11.x for Linux' started by LarsenD, Oct 18, 2012.

  1. LarsenD

    LarsenD Regular Pleskian

    22
    23%
    Joined:
    Apr 12, 2011
    Messages:
    131
    Likes Received:
    1
    The upgrade seems to finish fine and I couldn´t find any problems so far, but there is an error message shown while the upgrade is running:

    Preparing to replace php5-ioncube-loader 4.0.7-11102413 (using .../php5-ioncube-loader_4.0.14-12050719_amd64.deb) ...
    Unpacking replacement php5-ioncube-loader ...
    /var/lib/dpkg/info/php5-ioncube-loader.postrm: line 3: [: 0upgrade: integer expression expected

    Happened on every server I updated. This message originates from an Ubuntu 10.04.4. On Debian 6 the part with "postrm" was missing.

    This should be fixed for the next version.
     
  2. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
  3. LarsenD

    LarsenD Regular Pleskian

    22
    23%
    Joined:
    Apr 12, 2011
    Messages:
    131
    Likes Received:
    1
    Huh? This is a thread in the forum you mentioned...
     
  4. Nikolay.

    Nikolay. Silver Pleskian

    17
    35%
    Joined:
    Jul 1, 2012
    Messages:
    844
    Likes Received:
    2
    Funny, but in a sense it will be fixed no matter what, since this is a bug in a previous version (i.e. for Plesk 10.4.4, the script with error belongs to the old ionCube package). Also it seems like a minor dash incompatibility, rather than a general bug.
     
  5. LarsenD

    LarsenD Regular Pleskian

    22
    23%
    Joined:
    Apr 12, 2011
    Messages:
    131
    Likes Received:
    1
    Problem solved =)

    But only if that script isn´t also used by the new version of that package.
     
  6. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    Larsen for the sake for others, do you mind sharing how you resolved that problem?
     
  7. LarsenD

    LarsenD Regular Pleskian

    22
    23%
    Joined:
    Apr 12, 2011
    Messages:
    131
    Likes Received:
    1
    Hi Abdi,

    I was referring to Nikolay´s post. So, no real solution here.
     
Loading...