1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

10.1.1 Horde fatal error - help!

Discussion in 'Plesk 10.x for Windows Issues, Fixes, How-To' started by optikhog, Mar 2, 2011.

  1. optikhog

    optikhog Guest

    0
     
    This morning I upgraded our server from Plesk 9.5.2 to 10.1.1 and all went fine with the exception of Horde. At first, I was experiening a '500' error which, when viewed from the server, turned out to be a permissions issue for the Horde web directory (in my case, D:\inetpub\vhosts\webmail).

    I set those permissions appropriately and am now receiving the error:

    Warning: Wrong parameter count for class_exists() in D:\inetpub\vhosts\webmail\horde\pear\Log.php on line 142

    Warning: Wrong parameter count for class_exists() in D:\inetpub\vhosts\webmail\horde\pear\Log.php on line 147

    A fatal error has occurred
    An error has occurred. Furthermore, Horde encountered an error attempting to log this error. Please check your Horde logging configuration in horde/config/conf.php.

    I've spent all day trying to fix permissions in any place I can find but I just don't see anything wrong. Any ideas?

    Thanks.
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,576
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Strange. This bug was fixed since Plesk v10.0.0_build20100831.19.
    As possible workaround try to switch horde webmail off/on (recreate Horde site) - see that Horde works.
     
  3. optikhog

    optikhog Guest

    0
     
    Apparently not. I have already tried every step I could find in the forums - I have disabled/re-enabled Horde several times as well as run this command maybe 10 times:

    cd %plesk_bin%
    websrvmng --reconfigure-webmail

    Note that I have also set permissions to be wide open on the /tmp and /tmp/horde directories on the C: drive of our server where the logging seems to want to happen. I have also tried changing the logging directory to D:\horde with permissions wide open with no effect.

    I'm at a loss at this point. Any idea how to fix this? Is there something broken in the config file(s)?
     
  4. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,576
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    No. Try disable/enable it with webmailmng.
     
  5. optikhog

    optikhog Guest

    0
     
    I already have, several times. Both via the GUI and from the command line.
     
  6. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,576
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Are you sure that you have 10.1.1 version correctly installed?
     
  7. optikhog

    optikhog Guest

    0
     
    Is there a way to install it incorrectly? I used your installer and it reported no errors. We have not seen any other issues since the upgrade.
     
  8. optikhog

    optikhog Guest

    0
     
    Any ideas? Horde is still dead here. Are there any tips I can use from the fix you mentioned above?
     
  9. optikhog

    optikhog Guest

    0
     
    So should we assume that there is a problem with Plesk 10.1.1? Is there a plan to fix this problem? Hello?
     
  10. IanT

    IanT Basic Pleskian

    17
    35%
    Joined:
    Jul 13, 2010
    Messages:
    30
    Likes Received:
    0
    I have the same issue, ive create another thread but didn't see this one.

    i would say that this is a bug as there are too many people with the same issue
     
  11. optikhog

    optikhog Guest

    0
     
    Agreed. I started with the same 500 error you reported and ended up with this after fixing permissions. Did you do the same?
     
  12. IanT

    IanT Basic Pleskian

    17
    35%
    Joined:
    Jul 13, 2010
    Messages:
    30
    Likes Received:
    0
    no, i simply did an upgrade from 9.5.2 and after i started getting this error. Ive tried googling the error but there isn't anything useful.

    the only thing ive noticed in the event viewer when going to webmail is

    An unhandled win32 exception occurred in php-cgi.exe [6016]. Just-In-Time debugging this exception failed with the following error: Debugger could not be started because no user is logged on.

    Check the documentation index for 'Just-in-time debugging, errors' for more information.
     
  13. optikhog

    optikhog Guest

    0
     
    Same here.
     
  14. IanT

    IanT Basic Pleskian

    17
    35%
    Joined:
    Jul 13, 2010
    Messages:
    30
    Likes Received:
    0
    Please click one of the Quick Reply icons in the posts above to activate Quick Reply.
     
  15. IanT

    IanT Basic Pleskian

    17
    35%
    Joined:
    Jul 13, 2010
    Messages:
    30
    Likes Received:
    0
    ignore last post :)

    have you another webmail installed that works?
     
  16. optikhog

    optikhog Guest

    0
     
    Nope, we don't have the budget for any of the alternatives which work with mailenable standard.
     
  17. IanT

    IanT Basic Pleskian

    17
    35%
    Joined:
    Jul 13, 2010
    Messages:
    30
    Likes Received:
    0
    the only thing that could be tried is a manual install of a pop3 web based mail client but i have a feeling we would have the same php issue.

    Ive asked my customers to use pop3 access for the moment
     
  18. yunosh

    yunosh Guest

    0
     
    Sounds like the update includes a recent version of the PEAR Log package, but an old, incompatible version of PHP. Actually, this still seems to be PHP 4, which is dead.
    Downgrading to Log 1.11.6 would help.
     
  19. IanT

    IanT Basic Pleskian

    17
    35%
    Joined:
    Jul 13, 2010
    Messages:
    30
    Likes Received:
    0
    i meant to update this.

    Ive already downloaded PHP 5.3 and replaced php5.2 which is now allowing the php sites to load.

    Not very good support from Parallels.
     
  20. optikhog

    optikhog Guest

    0
     
    Did moving to php 5.3 resolve the problem? If so, did you do anything special to install?
     
Loading...