1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

10.3 Detected in Plesk 10.2 CP as AVAILABLE UPDATE!!!!

Discussion in 'Plesk 10.x for Windows Issues, Fixes, How-To' started by NeuroPsyche, Jul 16, 2011.

  1. NeuroPsyche

    NeuroPsyche Regular Pleskian

    26
    23%
    Joined:
    Nov 22, 2007
    Messages:
    207
    Likes Received:
    0
    Location:
    Pennsylvania, USA
    Please be carefull with 10.3...
    My Plesk 10.2 server has been saying that there is an update to 10.3 available and asked me if I wished to install it.
    It broke my Plesk 10.2 server but luckly I have backups and am restoring.

    Please be carefull with 10.3!!!! I thought that if it showed up in my Plesk 10.2 CP / Admin CP / Settings / Updates that it was now released full blown. I let my Plesk Update 'autoupdate'. The install ended with 'server connection error'... 'press refresh to continue' or something like that....

    I followed the instructions... I noticed that I had no more Plesk CP. IIS functions were also shut down.
    I thought that if the install did not finished my system would still be OK but it wasn't. I rebooted, no luck.
    Tried to restart IIS services, no luck... I called Plesk Tech Support and they said that it was only in BETA!!!!

    ... NOT to be installed on a production system. I told them that it was being auto-detected in Plesk 10.2 as an update, full update to 10.3... It did not say it was BETA.

    Luckly I have backups... and am restoring right now. Hopefully the server will be back to the way it was with a good 10.2 functioning...

    Please be carefull of this issue. I'm writing because when I called tech support they did not understand that my Plesk CP server detected it as an update. I mentioned to them that BETAs were always a 'manual download' and not EVER an update/upgrade that was detected or should EVER be detected by a production system!!!!

    ... they did not understand...
    So everyone... please let me know what's going on if this happens to you also. As either 10.3 was released and the tech did not know it and my system crashed as usual on the update/upgrade or that the 10.3 is still in beta and that my Plesk mistakenly picked it up as a auto-update.
     
  2. NeuroPsyche

    NeuroPsyche Regular Pleskian

    26
    23%
    Joined:
    Nov 22, 2007
    Messages:
    207
    Likes Received:
    0
    Location:
    Pennsylvania, USA
    Plesk 10.3 Screen shots attached. Plesk 10.3 Update showing in 10.2

    Screen shot files attached of Plesk 10.3 available in Plesk CP 10.2 / Settings / Update ...
    These are being shown as now available.

    Is this true? And was 10.3 actually released full ?
    Parallels tech said it was still in BETA...

    Can someone put some light on this?

    Thanks!
     

    Attached Files:

  3. dugjohnson

    dugjohnson Guest

    0
     
    Same situation

    10.3 appeared as an available update. I ran it. It bombed, and didn't finish. I was able to get my clients sites up again, but things are working weirdly inside Plesk now. And, you're right, no indication it was a beta. I wouldn't have installed it.
    Haven't had the time to back it out yet, so it is just being annoying...I was actually just looking for how to finish the 10.3 install when I came across this, that it is a beta.
    Now I need to see how to go backwards.
    Sigh.
    Love Plesk, usually, but this isn't fun.
     
  4. Kirill K

    Kirill K Regular Pleskian

    24
    53%
    Joined:
    Dec 24, 2007
    Messages:
    144
    Likes Received:
    0
    Guys,

    could you please provide your autoinstaller log (C:\{HASH}\autoinstaller3.log). Seems that It should help to answer on your problem.
    Thanks.
     
  5. NeuroPsyche

    NeuroPsyche Regular Pleskian

    26
    23%
    Joined:
    Nov 22, 2007
    Messages:
    207
    Likes Received:
    0
    Location:
    Pennsylvania, USA
    Hello Kriogen, regarding the installer logs ... After I spoke with technician on phone and he told me that 10.3 was still in BETA I restored the server to the previous backup... thus wiping all 10.3 logs so I do not have them. I'm back to running 10.2 until I get a confirmation that 10.3 if Final and officially released.

    Plesk CP 10.3 does not show as an available download on www.parallels.com nor is there any documentation on this version.

    Plesk CP 10.3 was detected as an available update and I let Plesk 10.2 download and install it. I have screen captures showing 10.2 detecting it as an available update. The 'Post Quick Reply' does not let me upload files. I'll post the screen captures in next post.

    Others, such as 'dugjohnson' may have the installer logs you need.

    Thank you!
     
  6. NeuroPsyche

    NeuroPsyche Regular Pleskian

    26
    23%
    Joined:
    Nov 22, 2007
    Messages:
    207
    Likes Received:
    0
    Location:
    Pennsylvania, USA
    Dug, I'm not sure if it is still in BETA or final release. My Plesk 10.2 install is showing it as an available update although no information is posted yet on parallels.com web site regarding 10.3..... as of this writing. Yes, I like Plesk very much also but have been waiting for a long time for them to update Sitebuilder. Sitebuilder 4.5 has been out, un-changed, since the early 2007-2008. Plesk CP's internal Sitebuilder 5.x was very much needed although I wish it still was a seperate program. I paid for Sitebuilder and would have gladly kept paying for it, if parallels/swsoft would have kept it current and revised it once in awhile.

    I restored my Plesk 10.3 back to previous backup, 10.2. ... this was done through server backup software, not through a 'go back' or anything like that. I don't trust Windows 'go back' and nothing can beat real backup / restore software. I really do suggest everyone have some sort of backup storage device on their servers as this will allow them to restore if a Plesk update/upgrade fails.... I've learned from previous Plesk installs that went bad that it (backup / restore software/hardware) is very much needed. Sorry I cannot help you with fixing your Plesk 10.3. I too wish I would be able to upgrade to 10.3 as I need the new features in Sitebuilder very bad. I have customers that thought that they could simply 'port' their Sitebuilder 4.5 sites to Sitebuilder 5.x but the realized that SB 5.x does not have the same modules to port their data to.... And when I say 'port' I mean a manual port. I wish there was a utility that could take 4.5 SB sites and migrate/port them to SB 5.x but I don't believe there is yet... It's on my wish list :)
     
  7. dugjohnson

    dugjohnson Guest

    0
     
    Log file

    I have attached the log file, renamed to have a txt extension per the requirements.
    Note that this is not from a Windows box, but a Centos 5 box. The file was in the /tmp directory.
     

    Attached Files:

  8. dugjohnson

    dugjohnson Guest

    0
     
    Need to finish update

    I am stymied. My server is working, but inside Plesk anything that accesses the tables gives an error based on the tables not being updated correctly. For instance, to turn off AutoReply for a user, I get an error that isLegacyUser is missing.

    According to yum I have the latest repository files. I am guessing that I need some way to finish or re-run the installation, but I haven't found it.

    Plesk still reports that it is 10.2. It is acting as if it is 10.3. Tables are at "who knows?" what level (probably 10.2 being called by 10.3 code).

    Is there a script that will just update the MySQL tables?
     
  9. dugjohnson

    dugjohnson Guest

    0
     
    Fixed...

    I was able to apply the 10.3.1 upgrade and it seems to have fixed everything.
     
Loading...