1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

29 seconds, the world is ending.

Discussion in 'Plesk for Linux - 8.x and Older' started by vision, Aug 22, 2005.

  1. vision

    vision Guest

    0
     
    New to plesk, running it on Fedora 2.

    I spent 25 hours over the weekend setting things up, learning testing, learning, testing.

    Things are going OK for the most part.

    I've noticed something very strange with FTP & SMTP connections to the server.

    When connecting to send a message (telnet server 25) from windows command prompt it connects, then sits there for exactly 29 seconds before sending the normal message:

    220 server ESMTP

    The same happens with FTP, I connect and login - password validated.

    Then I must sit there for 29 seconds, while it does something.

    Anyone know what it is?

    I read several posts here about the reverse name lookups being enabled in FTP but that is not the case here, as mine were off.
     
  2. jamesyeeoc

    jamesyeeoc Guest

    0
     
    The SMTP delay can be resolved by editing your /etc/xinetd.d/smtp_psa file and adding -Rt0 as shown below:

    <snip>service smtp
    {
    socket_type = stream
    protocol = tcp
    wait = no
    disable = no
    user = root
    instances = UNLIMITED
    server = /var/qmail/bin/tcp-env
    server_args = -Rt0 /var/qmail/bin/relaylock </snip>

    The delay with ftp has been posted about many times, but I do not think anyone has found a single cause for it. If I remember correctly, most have solved it by changing their proFTPd config to run as 'standalone' instead of under inetd or xinetd.
     
  3. vision

    vision Guest

    0
     
    Thanks!

    I don't know what -Rt0 does, but it does correct the 30 second delay when connecting to the SMTP erver.

    There seems to be a handful of problems that come up over and over, for anyone using Plesk. (ftp slow, smtp slow, file permissions etc). Is there an FAQ with the top problems anywhere?
     
  4. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Basically what it does is turn off Reverse lookups and sets the timeout to zero.

    I wish there were, then I wouldn't have to keep repeating answers every week... But hey, I've got nothing better to do, right?? Haahahha

    Best thing to do is browse through at least 2 to 4 weeks of post topics to get a feel for what the latest problems are.
     
Loading...