1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

2mb attachment limit on horde webmail

Discussion in 'Plesk for Linux - 8.x and Older' started by rossgile, Sep 23, 2005.

  1. rossgile

    rossgile Guest

    0
     
    I have set the limit size of mailboxes to 50mb in Plesk - however I can only send up to 2mb size file attachments in webmail.

    Any ideas here?

    - rg
     
  2. funkyade

    funkyade Guest

    0
     
    You need to edit your php.ini file (/etc/php.ini) so that it allows the size of attachment you require.

    you can do this by editing this section -

    PHP:
    ;;;;;;;;;;;;;;;;
    File Uploads ;
    ;;;;;;;;;;;;;;;;

    Whether to allow HTTP file uploads.
    file_uploads On

    Temporary directory for HTTP uploaded files (will use system default if not
    specified).
    upload_tmp_dir =/home/httpd/vhosts/tmp

    Maximum allowed size for uploaded files.
    upload_max_filesize 72M
    hope this helps.
     
  3. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Along with the upload_max_filesize, you may want to consider bumping the following values:

    /etc/httpd/conf.d/php.conf
    <Files *.php>
    SetOutputFilter PHP
    SetInputFilter PHP
    # max attachment size: 512 kbytes
    LimitRequestBody 524288
    </Files>
    Change LimitRequestBody value to what suits you.
    (by default, these lines are not in the file, you must add them! Change the value to BIGGER. Had to do this since Plesk 6 and when I used to sell web appliances... )

    /etc/php.ini
    post_max_size = 72M
    upload_max_filesize = 72M
    memory_limit = -1

    (I am lazy, so I set both these values to the same) Setting memory_limit to -1 or to a really big value may also help out. There are posts elsewhere which indicate if it's too small (like 16K default) that IMP will misbehave and attachments fail. I think I set it to 32M or 64M (must be larger than post_max_size and upload_max_size)
     
  4. rossgile

    rossgile Guest

    0
     
    YES - it helped. It was set at 2mb.

    I changed it. Do I need to do anything else to make it active?

    - rg
     
  5. jamesyeeoc

    jamesyeeoc Guest

    0
     
    I generally restart all related services, such as courier/imap, or if all else fails, reboot the server :)
     
  6. NorthLANs

    NorthLANs Guest

    0
     
    Thanks, this worked for me as well.
     
  7. ilya

    ilya Guest

    0
     
    Hi all. I am having a problem also, not be able to send attachments larger than 2 MB. The limit; however, is set to 20 MB and it is allowed also. The problem specifically looks like this: I click "send" with the 2 MB+ attachment and the page simply doesn't load and the message is not sent. Any ideas?
     
  8. teckna

    teckna Basic Pleskian

    25
    73%
    Joined:
    Nov 17, 2006
    Messages:
    53
    Likes Received:
    0
    hi, did you ever resolve the problem of the screen going blank when sending attach over the 2mb limit ??

    Ive got the same and searching for the answer of what to change !!


    thanks

    Andy
     
Loading...