• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

500 - Internal Server Error

JosefZ

New Pleskian
Hi, i just got an 500 - Internal Server Error on an Ubuntu 10.04 Server... Can you help me?
Error log prompts:

root@lvps83-169-3-40:~# service psa status
sw-cp-serverd (pid 1342) is running...

root@lvps83-169-3-40:~# tail /var/log/sw-cp-server/error_log
2012-12-11 10:34:30: (mod_fastcgi.c.1012) If this is PHP on Gentoo add fastcgi to the USE flags
2012-12-11 10:34:30: (mod_fastcgi.c.1105) [ERROR]: spawning fcgi failed.
[Tue Dec 11 10:34:35 2012] [apc-error] apc_mmap: mmap failed: Cannot allocate memory
2012-12-11 10:34:35: (mod_fastcgi.c.1000) the fastcgi-backend /usr/bin/sw-engine-cgi -c /opt/psa/admin/conf/php.ini -d auto_prepend_file=auth.php3 -u psaadm failed to start:
2012-12-11 10:34:35: (mod_fastcgi.c.1004) child exited with status 2 /usr/bin/sw-engine-cgi -c /opt/psa/admin/conf/php.ini -d auto_prepend_file=auth.php3 -u psaadm
2012-12-11 10:34:35: (mod_fastcgi.c.1007) if you try do run PHP as FastCGI backend make sure you use the FastCGI enabled version.
You can find out if it is the right one by executing 'php -v' and it should display '(cgi-fcgi)' in the output, NOT (cgi) NOR (cli)
For more information check http://www.lighttpd.net/documentation/fastcgi.html#preparing-php-as-a-fastcgi-program
2012-12-11 10:34:35: (mod_fastcgi.c.1012) If this is PHP on Gentoo add fastcgi to the USE flags
2012-12-11 10:34:35: (mod_fastcgi.c.1105) [ERROR]: spawning fcgi failed.
 
Back
Top