• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

7.1.6 - 7.5.0 database problem

T

the_raverX

Guest
OK, after quite a few issues upgrading PSA 7.1.6 to 7.5.0 I managed to get it all working..

Problem mainly was that I had been using AtomicRocketTurtle's updates, which all fell to pieces when I tried to update.

I read in the forums to do rpm -Uvh --just-db or something on the main PSA RPM, which I did (only have 7.5.0 rpm i used that, then forced install of that)..

now it looks like i've managed to omit a DB upgrade .. as when I went into the Mail->Mailing Lists section I got this:

ERROR
Up LevelUp Level
Unable to query: Table 'psa.exp_event' doesn't exist
0: /usr/local/psa/admin/plib/common_func.php3:2 psaerror(string "Unable to query: Table 'psa.exp_event' doesn't exist")
1: /usr/local/psa/admin/plib/api-rpc/loger.php:2 db_query(string "SELECT COUNT(*) FROM exp_event WHERE event_type = 'terminated' AND obj_class = 'dns_zone' AND source = 'plesk'")
2: /usr/local/psa/admin/plib/class.ActionLog.php:1 log_event(string "dns_zone", string "raverx.org", string "updated")
3: /usr/local/psa/admin/plib/class.dnsmng.php:2 actionlog->submit()
4: /usr/local/psa/admin/plib/class.dnsmng.php:2 logdnszoneupdate(string "domain", integer "106", string "raverx.org")
5: /usr/local/psa/admin/plib/class.DSMailLists.php:2 dnsmng->updatedomain(integer "106", string "raverx.org")
6: /usr/local/psa/admin/plib/class.DSMailLists.php:2 dsmaillists->update()
7: /usr/local/psa/admin/htdocs/domains/maillists/maillists.php:2 dsmaillists->create()

Any ideas what I can do to fix?
 
In 'psa' database's 'misc' table what does the "version" field say?
 
version 0750

i would say by that it half updated the db?? i do have a backup from last nite of the psa database if i needed to restore it..
 
It's updated the DB then. Did you get any error messages after the initial upgrade?
 
===> Reading /etc/psa/psa.conf ...

Trying to stop MySQL server... done

ERROR while trying to stop MySQL server
Check the error reason(see log file: /tmp/psa_7.5.0_RedHat_el3_build75041208.19_upgrade.log), fix and try again

Aborting...

error: %pre(psa-7.5.0-rhel3.build75041208.19) scriptlet failed, exit status 1
error: install: %pre scriptlet failed (2), skipping psa-7.5.0-rhel3.build75041208.19
Generate public/private keys pair for server ...
domain_bu: db_connect: failed to connect to database: Error: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
domain_bu: db_connect: failed to connect to database: Error: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
Can't connect to MySQL database: No such file or directory
domain_bu: db_connect: failed to connect to database: Error: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
domain_bu: db_connect: failed to connect to database: Error: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
Can't connect to MySQL database: No such file or directory
Server keys generating done
===> Reading /etc/tomcat4/tomcat4.conf ...
===> Updating /etc/psa/psa.conf...
===> Reading /etc/psa/psa.conf ...

ERROR 2002: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
db_connect: failed to connect to database: Error: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
db_connect: failed to connect to database: Error: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
Key register failed
/var/tmp/rpm-tmp.81598: line 18824: 18484 Terminated /usr/local/psa/admin/bin/php /usr/local/psa/installer/api/install_db.php
error: %post(psa-api-rpc-1.3.2-3) scriptlet failed, exit status 143
===> Reading /etc/psa/psa.conf ...
/usr/local/psa/admin/bin/httpsdctl stop: httpd stopped
Stopping Plesk: [ OK ]

uninstall_post.sh
 
ok, chased through that last script and ran it .. seems to have fixed everything

/usr/local/psa/admin/bin/php /usr/local/psa/installer/api/install_db.php

thanx for your help, helped point me in the right direction :)
 
Back
Top