1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

[7.5.3] No hard disk quota at hosting setup

Discussion in 'Plesk for Linux - 8.x and Older' started by plugged, Jul 6, 2005.

  1. plugged

    plugged Guest

    0
     
    I've just installed Plesk 7.5.3 on my new server:
    Celeron 2.4GHz
    1024MB ram
    250GB Hard disk
    OS: FreeBSD 5.3

    Everything seems to be working fine, even the Perl packages missing in the Plesk installer is installed.

    But when I add a domein, I can't use the hard disk quota. It seems to be not working because the input box is gray...

    Though I can use the limits...

    Can somebody tell me what's wrong?
     
  2. saschahb

    saschahb Guest

    0
     
    Please check if the quota utils (quota rpm or deb package) are installed and the filesystem supports the quota...

    greets
    sascha
     
  3. plugged

    plugged Guest

    0
     
    As far as I know, quota is enabled.

    This is what I see in my /etc/fstab
    Code:
    $ cat /etc/fstab
    # Device                Mountpoint      FStype  Options         Dump    Pass#
    /dev/ad0s1b             none            swap    sw              0       0
    /dev/ad0s1a             /               ufs     rw              1       1
    /dev/ad0s1e             /tmp            ufs     rw              2       2
    /dev/ad0s1f             /usr    ufs     rw,userquota    2       2
    /dev/ad0s1d             /var            ufs     rw              2       2
    /dev/acd0               /cdrom          cd9660  ro,noauto       0       0
    linprocfs               /compat/linux/proc   linprocfs   rw   0  0
    
    /dev/ad0s1f /usr ufs rw,userquota 2 2

    According this line, it should be enabled...
     
  4. swebs

    swebs Guest

    0
     
  5. plugged

    plugged Guest

    0
     
    Re: I had the same problem

    Done that, now I got error messages :mad:

    Unable to assign variables for PHostingForm: Unable to get hardquota state: usermng failed: Empty error message from utility.

    --------------------------------------------------------------------------------

    0: /usr/local/psa/admin/htdocs/domains/hosting/phosting_setup.php:288 psaerror(string "Unable to assign variables for PHostingForm: Unable to get hardquota state: usermng failed: Empty error message from utility.")

    I've put the original one back.

    I don't think this is it ...
     
  6. plugged

    plugged Guest

    0
     
    got anyone a clue for me?
     
  7. jamesyeeoc

    jamesyeeoc Guest

    0
     
    I would recommend doing one of the following:

    1. Change into the directory where the Plesk rpms are stored, do rpm -Uvh --force *.rpm

    2. Setup yum and use ARTs yum channels and do yum update

    3. Try the control panel updater again (least likely to work)

    Eventhough you've just done a fresh install, it is likely that something just didn't install properly. Forcing the rpm's to reinstall may be the more likely fix.
     
  8. plugged

    plugged Guest

    0
     
    That ain't gonna work, i'm using FreeBSD, not Fedora.
     
  9. plugged

    plugged Guest

    0
     
    Damn...

    I've just installed Fedora Core 2 on the server, and now Plesk is running Perfectly... everything works great!

    But i still want to use FreeBSD!

    Can anybody tell me what I'm not seeing?
    On FreeBSD i've got a normal BSD filesystem with quota enabled (like all default installs). I've installed Perl 5.8.6 with all other extra packages.

    I'm clueless :(
     
  10. steve0

    steve0 Guest

    0
     
    I do not believe that quota support is included in GENERIC kernel on FreeBSD. You will have to enable quota support in the kernel and then recompile. Once you have done this plesk will be ok with quotas .
     
Loading...