1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

7.54 Hotfix & Plesk migration manager upgrade error

Discussion in 'Plesk for Linux - 8.x and Older' started by Pagemakers, Mar 28, 2006.

  1. Pagemakers

    Pagemakers Silver Pleskian

    31
    80%
    Joined:
    Dec 19, 2007
    Messages:
    664
    Likes Received:
    7
    I get the following error after I run the Plesk migration manager updater. My server has plenty of free space:

    Download file versions.inf3: 38%..100% done
    Download file PSA_7.5.4/plesk-7.5.4-fc3-i386.inf3: 100% done
    Checking for system installed packages...done.
    Check for components installation status
    Reading system installed packages...done.
    Download file plesk-7.5.4-fc3-i386.hdr.gz: 82%..100% done
    Download file plesk-7.5.4-fc3-i386.hdr.gz: 31%..71%..100% done
    Resolve components
    There are some also needed components will installed too: 'base'
    Get Plesk product packages.
    Download file opt/migration/psa-migration-manager-7.5.4-fc3.build75060321.20.i586.rpm: 42%..88%..100% done
    Get system update packages.
    ERROR: Not enough space for product installation: In directory /opt the are 300 Mb is required
    but available only 248 Mb.


    ---
    Plesk autoinstaller.
     
  2. JD Austin

    JD Austin Guest

    0
     
    make sure by logging in as root (I assume this is a linux/unix box) and type:
    df -h
     
  3. phatPhrog

    phatPhrog Guest

    0
     
    Plesk 7.5.4 Not enough space for product installation

    Log in as root?

    This is obviously a Plesk 7.5.4 UPDATER error.

    Logged in as owner/admin/root whatever in the main administration of our server via Plesk 7.5.4/FC2 all updates/patches applied.

    BEFORE updating the BASE package, this error does not occur. Also, before updating the BASE package our latest version indicated an Aug 24, 2005 with an available update of Mar 21, 2006.

    After updating the BASE package the current version still indicates we have the latest version as of: Aug 24, 2005. (even after rebooting the test server)

    We have just verified this error with a second server.

    After using the updater for BASE, we then attempted further updates for watchdog and bu, which resulted in the following error(s):
    ....and did so again to be sure, which resulted in the same error with the only change being the available space being 89 Mb, then 87Mb, then 85Mb.

    We are The Plesk, Resistance is Futile.....

    Come on guys, give us a break. Help us here.

    Must be something in the new base code update that changes something.

    Hope for some postive feedback so The Plesk can continue to absorb the world.

    heheheheeee....

    EDIT
    So sorry---

    my

     
  4. webfinesse

    webfinesse Guest

    0
     
    I was getting the same error

    /opt is part of the / in your case you only have 63 mb available

    I went and cleaned up my /root folder and that got me plenty of space to do the install.

    Perhaps in the future plesk should let you specifiy where to download things to and install.

    I fear that if the /opt is continued to be used it will cause problems. According to their docs when I origianlly installed the software SWSoft said 1GB of / is enough. Appearently now this is not the case

    Best Wishes
     
  5. JD Austin

    JD Austin Guest

    0
     
    [root@ admin]# df -h
    Filesystem Size Used Avail Use% Mounted on
    /dev/hda1 479M 392M 63M 87% /
    none 502M 0 502M 0% /dev/shm
    /dev/hda7 63G 568M 63G 1% /home
    /dev/hda5 4.7G 1.6G 3.2G 33% /usr
    /dev/hda6 4.7G 399M 4.3G 9% /var

    I've had my own issues with plesk, but in this case the error message you're getting is absolutely correct...

    /dev/hda only has 63M available out of 479M

    There is no /opt mount point so it's going in / .
    Clear up space in / and try again.

    Alternately you can move the directory and create a symlink.
     
  6. phatPhrog

    phatPhrog Guest

    0
     
    /opt mount point

    Thanks, but been there, done that...and nothing has resolved this issue.

    Have you checked how many /opt directories there are?

    I have just gone through our test server and manually deleted the contents of EACH /opt directory one by one, rebooted the TEST server, after each when nothing changes and each time receive the same error.

    If the contents of "whatever" /opt directory on a Plesk 7.5.4 server cannot be cleared, what holds onto it?

    More importantly, why did this problem start with the latest Plesk 7.5.4 BASE update using the Plesk 7.5.4 update option in the administrator/server control panel.

    Don't misunderstand my tone.....not being testy.....just stating the obvious from our point-of-view.

    Thank you so much JD Austin
     
  7. webfinesse

    webfinesse Guest

    0
     
    the actual opt it is using is opt directory directly under /

    /
    +--opt

    Basically you need to free up your / partition or do what JD suggested

    If that is not the solution to your problem I am afraid I cannot be of anymore help

    Good Luck :)
     
  8. JD Austin

    JD Austin Guest

    0
     
    The error is a space issue. On my server the plesk files go in /root/psa look in the log file to see where yours are going. Then move the directory to one of your other mount points with a lot of space (not /).

    For example:
    on my mserver the file in question is located here:
    /root/psa/PSA_7.5.4/rpm_RedHat_9/opt/
    Check that yours is in the same place.. if it is, try this:

    I'd move the whole psa directory to /home in your case (since it is the largest).
    Log in as root:
    mv /root/psa /home/.
    ln -s /home/psa /root/psa
     
  9. phatPhrog

    phatPhrog Guest

    0
     
    Move PSA

    Thanks, I will try that, however...

    I have deleted that whole directory on our test server and am still unable to update.

    Perhaps I missed something.

    Your obvious success makes that obvious, so I'll let you and everyone in need if and when I succeed.

    Again, thank you once more.
     
  10. phatPhrog

    phatPhrog Guest

    0
     
    1and1 dedicated

    I am totaly confused now.

    Seems I have the same contents in none of which can be removed and/or overwritten:

    This is on a test server we just re-imaged and tried to run updates on once more.

    What am I missing, please?
     
  11. JD Austin

    JD Austin Guest

    0
     
    It looks like you have PSA_7.5.4 in /root.
    Move it the same way and symlink it.

    If you're re-imaging give / more space.
     
  12. phatPhrog

    phatPhrog Guest

    0
     
    1and1

    Here is what we have

    /opt - empty
    /root/opt/psa - updates minus one day
    /home/opt/psa - current attempts of updates

    Is this a Plesk 7.5.4 thing with the latest BASE update?
     
  13. Pagemakers

    Pagemakers Silver Pleskian

    31
    80%
    Joined:
    Dec 19, 2007
    Messages:
    664
    Likes Received:
    7
    We too are 1&1. We sorted this by creating a simlink.

    # ln -s /var/psa /root/psa

    Messy I know and I think this is a big in the latest Plesk update.
     
  14. JD Austin

    JD Austin Guest

    0
     
    I stumbled upon a simpler solution to your issue.

    create a psa directory on a mountpoint that has a lot of free space (/var or /home).
    Then set the temporary download directory in plesk to that directory by going to
    server -> updater-> preferences
     
  15. Pagemakers

    Pagemakers Silver Pleskian

    31
    80%
    Joined:
    Dec 19, 2007
    Messages:
    664
    Likes Received:
    7
    Had that set up already but it still didn't work.
     
  16. phatPhrog

    phatPhrog Guest

    0
     
    Sym link already there

    We already have a sym link as well.

    J.DAustin --- we already have symlinks established with our 1and1 server as you provide.

    Deleting the contents of each directory does nothing (leaving the symlink in tact).

    Even took the extreme of reimaging two of our test servers to see the results and could not resolve the issue.

    Test server one/two we ran an update ONLY on base packages without error.

    Test server two we ran an update ONLY on watchdog and BU receiving the same error WITHOUT running a prior update on base packages.

    We have completed multiple reimages on both servers, attempting updates via the Plesk 7.5.4 update option/manual updates and cannot perform a full update under any cirumstances.

    This is not a HOSTING problem, it is Plesk related only for those of you using a 1and1 dedicated package (to the best of our knowledge)

    Each occurence reflects a 2meg difference in the directory /opt.

    Removing the contents of ALL occurences of /opt does not resolve the issue.

    Creating a new sym link for the update also provides no further positive results.

    This MUST be in direct relation to Plesk 7.5.4.
     
  17. CCHickman

    CCHickman Regular Pleskian

    25
    40%
    Joined:
    Oct 11, 2003
    Messages:
    112
    Likes Received:
    0
    symlinks save the day!

    I wanted to jump in and talk a little bit about my experience with symlinks.

    1and1.com's server partitioning is ridiculous and is not condusive to a busy server. Creating symlinks to get around the limitations is a ridiculously simple and beautiful way of fixing the problems!

    For instance, 1and1.com provide a 5GB partition for both e-mail and for MySQL databases. Suffice to day, I have over 90 accounts on my server and this is not enough!

    For a while, I found myself doing maintainance on my clients' e-mail boxes -- finding out if certain clients had e-mail accounts that were forwarding addresses with the mailbox option turned on and optimizing my databases just to continually find a way to keep the ship from sinking.

    mkdir /home/qmail
    service qmail stop
    mv /var/qmail/mailnames /home/qmail
    ln -s /home/qmail /var/qmail/mailnames

    =) - amazing.

    The same goes with /opt ... I'm finding that my server and symlinks not only get around these problems, but also allow my PLESK related files to all be accessed via /home, which is a little more convenient.

    - Chris
     
Loading...