1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

9.2.2 All Emails from Apached Not delivered

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by RaymondB, Sep 30, 2009.

  1. RaymondB

    RaymondB Guest

    0
     
    I have our normal email programs on our desktops working.

    When we rely on Apache to send us an email via a PHP program it never arrives.

    What happened? How can I fix this?

    I checked the queue and a number of bounces messages are coming back like this:

    Reporting-MTA: dns; 22-22-22-123.xxx.dedicated.xxx.com
    X-Postfix-Queue-ID: 58D1C1BF0D52
    X-Postfix-Sender: rfc822; 22-22-22-123.xxx.dedicated.xxx.com
    Arrival-Date: Tue, 29 Sep 2009 18:06:37 -0700 (PDT)

    Final-Recipient: rfc822; xxx@aol.com
    Original-Recipient: rfc822;xxx@aol.com
    Action: failed
    Status: 5.0.0
    Remote-MTA: dns; mailin-01.mx.aol.com
    Diagnostic-Code: smtp; 550 REQUESTED ACTION NOT TAKEN: DNS FAILURE
     
  2. Andrey Kucherov

    Andrey Kucherov Guest

    0
     
  3. RaymondB

    RaymondB Guest

    0
     
    Please click one of the Quick Reply icons in the posts above to activate Quick Reply.
     
  4. RaymondB

    RaymondB Guest

    0
     
    The answer is not what you have suggested.

    The problem is that postfix is not configured correctly. Whether plesk is supposed to support this or not is debatable from a user's standpoint. I would imagine there should be a configuration for setting this and discovering it. However you have pointed me at the incorrect document.

    The issue is that Postfix was defaulting to "localhost" for the domain. When the reverse DNS check was done by AOL the emails were resolving to the localhost aka "name_of_computer" and not my domain.

    I followed the following steps to resolve this issue. None of which had to do with anything but a problem regarding postfix configuration/plesk setup.
    I did ensure that the DNS MX records were pointing to mail.domain.com in my case. They already were. So I could check that off the list without touching a thing.
    Then I went to http://www.mxtoolbox.com/Public/Tools/MxLookup.aspx and found out that my Reverse DNS did not match Banner. Meaning when AOL was doing a reverse DNS Check it was returning something other than my MX record for the server.. the localhost aka "name_of_computer" and not my domain. Source of the problem.
    So I found this link which gave me tips on how to configure postfix: http://www.howtoforge.com/forums/archive/index.php/t-6962.html

    I ran:
    postconf -e 'mydestination = $myhostname, localhost.$mydomain, localhost'
    postconf -e 'myhostname = mail.mydomain.com'
    postconf -e 'mydomain = $myhostname'
    and restarted Postfix afterwards.

    This solved the Reverse DNS check/Reverse DNS matches SMTP Banner problem. The emails stopped being rejected and were being delivered shortly afterward.
     
Loading...