1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Adjusting Horde Attachment Size

Discussion in 'Plesk for Linux - 8.x and Older' started by webcustoms, Jun 18, 2007.

  1. webcustoms

    webcustoms Guest

    0
     
    adjusting horde attachment size in php.ini - changes not effective

    I have reviewed probably every thread on here for upping the upload limit for horde, but I just cannot seem to pull it off.

    I am running Plesk 8.1, (psa v8.1.1_build81070322.16 os_RedHat el4)

    I have edited the following parameters in /etc/php.ini, and have rebooted the entire server:

    file_uploads
    upload_max_filesize
    max_input_time
    memory_limit
    max_execution_time
    post_max_size

    They look like this on their appropriate lines:

    ;;;;;;;;;;;;;;;;
    ; File Uploads ;
    ;;;;;;;;;;;;;;;;

    ; Whether to allow HTTP file uploads.
    file_uploads = On

    ; Temporary directory for HTTP uploaded files (will use system default if not
    ; specified).
    ;upload_tmp_dir =

    ; Maximum allowed size for uploaded files.
    upload_max_filesize = 16M

    ;;;;;;;;;;;;;;;;;;;
    ; Resource Limits ;
    ;;;;;;;;;;;;;;;;;;;

    max_execution_time = 360 ; Maximum execution time of each script, in seconds
    max_input_time = 600 ; Maximum amount of time each script may spend parsing request data
    memory_limit = 32M

    ; Maximum size of POST data that PHP will accept.
    post_max_size = 16M



    So, the deal goes, after I have edited /etc/php.ini above, rebooted the server, I go into horde and try to upload an attachment, and anything above 2MB just spits out an Internet Explorer error.

    I uploaded a test script to the web server and it shows that none of the php parameters have been changed.

    What is going on? Why are my php parameters not loading? Is there a Plesk specific config file hidden somewhere else on the system that I don't know about?

    Would appreciate some help on this matter, it seems like an on-going issue on this forum that really hasn't had a definite answer yet.

    Thanks,
    Ray.
     
  2. webcustoms

    webcustoms Guest

    0
     
    Can anyone help me here?
     
  3. sieb@

    sieb@ Guest

    0
     
    http://kb.swsoft.com/en/1075

    Although it says Windows, the same changes work properly on my linux machines.

    BTW, no need to reboot the machine after changing, just: service httpd stop, then a service httpd start. (may have to stop a couple times to stop all threads)
     
  4. webcustoms

    webcustoms Guest

    0
     
    Thanks for the reply. I did make those changes earlier, but they didn't work. I ended up solving the problem by deleting php.ini and re-creating it. (weird) prolly something to do with selinux.
     
  5. MrBafner

    MrBafner Guest

    0
     
    I too have tried changing just about everything that I can to adjust the 2 mb limit.
    I need to set up 1 site as to allow greater files than 2mb in a php upload script.

    I have tried both, 10mb and 10000000 in the php.ini and neither works.

    Does anyone have any suggestions?

    Or better yet a descent http...ftp drag & drop script.
     
  6. benji

    benji Guest

    0
     
    Hi, i've solved the problem for plesk 8.1 + CentOS 4.5

    This is how i configured my php.ini params:
    PHP:
    max_execution_time 560
    max_input_time 
    400
    memory_limit 
    342M
    //(yes, it is very big, but seems like horde needs it for the attach, bad programing??)
    upload_max_filesize 15M
    i believe didnt modify any other params to solve...
    Hope that helps.
     
Loading...