• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

After JSON install PHP is throwing error

R

RadNadz

Guest
SOLVED: After JSON install PHP modules doesn't have json.so

php -v gives:

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/json.so' - /usr/lib/php/modules/json.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP 5.1.6 (cli) (built: Nov 29 2010 16:47:37)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies
with the ionCube PHP Loader v4.0.7, Copyright (c) 2002-2011, by ionCube Ltd.

I installed JSON using the directions given here (the non-manual). But it looks like json.so was not installed in the modules dir and find is not seeing any file by that name anywhere on the server. Where can I get the missing file to finish the install? I'm about to rip my hair out. Any help would be greatly appreciated. I can't pull off the bald look...

EDIT: Gotta love misreading an l as a 1.
 
Last edited by a moderator:
Back
Top