• Halloween is coming! To celebrate the occasion, we dusted off a couple of old skins, and even created a brand new one (Pixel).
    To get into the festive spirit, install the Skins extension.
  • The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • The Plesk Mobile apps for iOS and Android and the Plesk Mobile Center extension have been deprecated, and are no longer available for new installations. In Plesk Obsidian 18.0.84, the Plesk Mobile Center extension will be removed from servers during the upgrade, and the Plesk Mobile apps will lose their server management features.
  • The Social Login extension has been deprecated and will be removed in Plesk Obsidian 18.0.84. After that, it will no longer be possible to log in to Plesk with a Google, Facebook, GitHub account, or with a passkey. Plesk usernames and passwords, as well as logging in with a WebPros Account, are not affected.

Issue All Domains Apache2/Error 500

Hello, i have the problem since today morning at my 2 servers at all FPM sites with ubuntu 20.04 i mean after the updates :

apache2 2.4.41-4ubuntu3.5 vom Repository Ubuntu for focal-updates by Ubuntu (vorherige Version: 2.4.41-4ubuntu3.4 vom Repository now)
- apache2-bin 2.4.41-4ubuntu3.5 vom Repository Ubuntu for focal-updates by Ubuntu (vorherige Version: 2.4.41-4ubuntu3.4 vom Repository now)
- apache2-data 2.4.41-4ubuntu3.5 vom Repository Ubuntu for focal-updates by Ubuntu (vorherige Version: 2.4.41-4ubuntu3.4 vom Repository now)
- apache2-utils 2.4.41-4ubuntu3.5 vom Repository Ubuntu for focal-updates by Ubuntu (vorherige Version: 2.4.41-4ubuntu3.4 vom Repository now)
- libdrm-common 2.4.105-3~20.04.2 vom Repository Ubuntu for focal-updates by Ubuntu (vorherige Version: 2.4.105-3~20.04.1 vom Repository now)
- libdrm2 2.4.105-3~20.04.2 vom Repository Ubuntu for focal-updates by Ubuntu (vorherige Version: 2.4.105-3~20.04.1 vom Repository now)
- libnetplan0 0.103-0ubuntu5~20.04.1 vom Repository Ubuntu for focal-updates by Ubuntu (vorherige Version: 0.102-0ubuntu1~20.04.2 vom Repository now)
- linux-firmware 1.187.17 vom Repository Ubuntu for focal-updates by Ubuntu (vorherige Version: 1.187.16 vom Repository now)
- netplan.io 0.103-0ubuntu5~20.04.1 vom Repository Ubuntu for focal-updates by Ubuntu (vorherige Version: 0.102-0ubuntu1~20.04.2 vom Repository now)
- postfix 3.4.13-0ubuntu1.2 vom Repository Ubuntu for focal-updates by Ubuntu (vorherige Version: 3.4.13-0ubuntu1.1 vom Repository now)
- postfix-pcre 3.4.13-0ubuntu1.2 vom Repository Ubuntu for focal-updates by Ubuntu (vorherige Version: 3.4.13-0ubuntu1.1 vom Repository now)
- python3-update-manager 1:20.04.10.9 vom Repository Ubuntu for focal-updates by Ubuntu (vorherige Version: 1:20.04.10.7 vom Repository now)
- update-manager-core 1:20.04.10.9 vom Repository Ubuntu for focal-updates by Ubuntu (vorherige Version: 1:20.04.10.7 vom Repository now)
 
The article from Plesk doesn't help me, the first command returns this error (Ubuntu 18.04):

The following packages have unmet dependencies:
apache2 : Depends: apache2-bin (= 2.4.29-1ubuntu4) but 2.4.29-1ubuntu4.17 is to be installed
Depends: apache2-utils (= 2.4.29-1ubuntu4)
Depends: apache2-data (= 2.4.29-1ubuntu4) but 2.4.29-1ubuntu4.17 is to be installed
E: Unable to correct problems, you have held broken packages.
 
This article doesn't work for me:

apt list -a apache2
Listing... Done
apache2/now 2.4.41-4ubuntu3.5 amd64 [installed,local]
export version="2.4.41-4ubuntu3"; apt-get install apache2=$version apache2-utils=$version apache2-data=$version apache2-bin=$version
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Version '2.4.41-4ubuntu3' for 'apache2' was not found
E: Version '2.4.41-4ubuntu3' for 'apache2-utils' was not found
E: Version '2.4.41-4ubuntu3' for 'apache2-data' was not found
E: Version '2.4.41-4ubuntu3' for 'apache2-bin' was not found

OS
Ubuntu 20.04.3 LTS
Product
Plesk Obsidian
Version 18.0.38 Update #2, last updated on Sept 21, 2021 03:18 AM
 
Yes, had this automatic update on our server lastnight, killed 80 websites instantly...

Ran these commands to update to Apache 2.4.49 (Which has fixed the problem for me) - for anyone who isn't tech savvy.

Code:
sudo add-apt-repository ppa:ondrej/apache2
sudo apt install apache2
Man, you saved my life ! Thanks
 
Yes, had this automatic update on our server lastnight, killed 80 websites instantly...

Ran these commands to update to Apache 2.4.49 (Which has fixed the problem for me) - for anyone who isn't tech savvy.

Code:
sudo add-apt-repository ppa:ondrej/apache2
sudo apt install apache2
we were about to restore our last snapshots and you save us hours. Thanks! It did the job.
 
500 error just killed everything.
Both downgrading to 2.4.41-4ubuntu3 and upgrading to 2.4.49 via ondrej repo worked except for mod_rewrite, regardless of FastCGi or PHP-FPM
 
Yes, had this automatic update on our server lastnight, killed 80 websites instantly...

Ran these commands to update to Apache 2.4.49 (Which has fixed the problem for me) - for anyone who isn't tech savvy.

Code:
sudo add-apt-repository ppa:ondrej/apache2
sudo apt install apache2
This is the one for most it seems - worked for us all sites back up no problems
 
Get Versions, choose an earlier version, 2.4.29-1ubuntu4 may not be your system so adjust the install command (below) to an earlier version that you see.
Code:
apt list -a apache2

Downgrade version (some dependancies)
Code:
apt-get install apache2=2.4.29-1ubuntu4 apache2-bin=2.4.29-1ubuntu4 apache2-utils=2.4.29-1ubuntu4 apache2-data=2.4.29-1ubuntu4

I'm trying to follow this procedure but I am stuck. When I run

Code:
apt list -a apache2

This is what I get:

Code:
/etc/apache2/sites-enabled$ apt list -a apache2

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Listing...
apache2/bionic 2.4.49-3+ubuntu18.04.1+deb.sury.org+2 amd64 [upgradable from: 2.4.29-1ubuntu4.17]
apache2/bionic-updates,bionic-security,now 2.4.29-1ubuntu4.17 amd64 [installed,upgradable to: 2.4.49-3+ubuntu18.04.1+deb.sury.org+2]
apache2/bionic 2.4.29-1ubuntu4 amd64

So, at this point, what should I do?
 
Back
Top