1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Alternate port SMTP

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by Kiwilink, Jan 13, 2009.

  1. Kiwilink

    Kiwilink Guest

    0
     
    Hi there,

    When we were on plesk 8.6 we had port 2025 open for SMTP (as some ISP's block port 25). We did the upgrade to 9 through the plesk updater and everything else runs fine, but port 2025 has stopped accepting mail. I don't recall the process we used to do this originally.

    Our /etc/services file still has the line: smtp2 2025/tcp mail # alt smtp port

    Can anyone throw me a bone here? We have quite a few customers using 2025 and me pulling my hair out.

    P.S: I have full access to the server, we own it, it runs Plesk 9 and Debian 4.

    Thanks.
     
  2. Brujo

    Brujo Regular Pleskian

    28
    57%
    Joined:
    Mar 4, 2006
    Messages:
    278
    Likes Received:
    2
    Location:
    Germany
    i am not sure, on my box this is done on /etc/xinetd.d/

    therefore you need a second one like smtp2_psa with the defined service and of course on the FW the port have to be opend. Another option would be also to use the standart submission port which is running on 587 as formalized in RFC 4409, for relaying outbound mail to a mail server and you can switch it on/off in the Plesk CP.

    Brujo
     
  3. Kiwilink

    Kiwilink Guest

    0
     
    Thanks, That was the right direction.

    In summarary, in case anyone finds this thread in the future to need to do this, here is the full instructions in one easy go:

    In /etc/xinetd.d/ There is a file called smtp_psa, you will need to copy this file to another filename (in the example I'll use smtp2_psa).

    Open up this file for editing (vi, note you will need to be rootly) and change the line "service smtp" to "service smtp2"

    Once this is complete, you will need to modify your /etc/services file, and add the smtp2 service: "smtp2 2025/tcp mail"

    Then restart xinetd. (/etc/init.d/xinetd reload)

    And then your good to go. Try doing a telnet (telnet <domain> 2025) to make sure it is working and then set up mail clients. Remember that you can use any available port for the mail, 2025 is what I chose. If this does not work try doing "telnet 127.0.0.1 2025" from the a session on the machine itself, if this works then it means that you need to open the port on an external firewall.
     
  4. dopesheet

    dopesheet Guest

    0
     
    Had problem with port 587 after upgrade

    After upgrading Plesk, users using port 587 were getting log in errors when trying to send mail through outlook. The problem was with the shortnames setting, which for some reason was removed during the upgrade. Everyone had set up their email using their shortname login, not their entire email address.

    I added this line into /etc/xinetd.d/smtp_psa_alt

    restarted xinetd

    viola!
     
  5. raz3k

    raz3k Basic Pleskian

    23
    23%
    Joined:
    Nov 12, 2006
    Messages:
    25
    Likes Received:
    0
    postfix alternate smtp port without rbl check

    For people who want an alternate port that does not query the rbl. I use this for clients that i am certain that they are not sending spam but they are using an adsl connection.

    vi /etc/master.cf

    add this line:

    desiredportno inet n - - - - smtpd -o smtpd_proxy_filter=127.0.0.1:10025 -o smtpd_client_restrictions=
    or
    desiredip:desiredportno inet n - - - - smtpd -o smtpd_proxy_filter=127.0.0.1:10025 -o smtpd_client_restrictions=

    and then /etc/init.d/postfix restart after that you can check that everything is working using:

    telnet desiredip desiredport OR
    netstat -antepula | grep desiredportno

    in my case it shows:
    tcp 0 0 0.0.0.0:1025 0.0.0.0:* LISTEN 0 6164199 31406/master

    Good luck
     
  6. esbon

    esbon Basic Pleskian

    24
    23%
    Joined:
    Sep 16, 2006
    Messages:
    66
    Likes Received:
    0
    Thanks for this help. I just switched from qmail to postix on Plesk 9.5.4 and I had the same problem with port 587 so I added 587 inet n - - - - smtpd -o smtpd_proxy_filter=127.0.0.1:10025 -o smtpd_client_restrictions= to the master.cf file and it started working, but email could not be sent from port 25 anymore so I then added:
    25 inet n - - - - smtpd -o smtpd_proxy_filter=127.0.0.1:10025 -o smtpd_client_restrictions= and it began working again. Is this a safe thing to do. I don't don't understand why port 25 stopped working; should I do anything else.

    Thanks for helping

    Miguel
     
Loading...