1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

API to select horde Webmail

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by AronD, Aug 27, 2010.

  1. AronD

    AronD Guest

    0
     
    Plesk version: 9.5.2
    Linux: CentOS 5

    Problem:

    Im using the Plesk API to setup clients, domains and email addresses. On some ocassions I need to enable Horde webmail for a domain which works fine when selected manually. The problem comes about when Im trying to select the appropriate webmail program for a particular domain using the API.

    screenshot below shows the options Ive given for selecting webmail manually through Plesk. All I want to do is change the Webmail drop down from 'None' to 'Horde 4.3.6' using the API.

    [​IMG]

    However according to the API documentation http://download1.parallels.com/Plesk/PPP9/Doc/en-US/plesk-9.3-api-rpc/index.htm?fileName=34479.htm The webmail option is a boolean of either true or false.

    Does anyone know how I can select the Horde webmail ?

    Here is the packet im sending to the API:

    <?php
    $packet = <<<EOP
    <?xml version="1.0" encoding="UTF-8"?>
    <packet version="1.5.2.1">
    <mail>
    <set_prefs>
    <filter>
    <domain_id>$domain_id</domain_id>
    </filter>
    <prefs>
    <nonexistent-user>
    <reject/>
    </nonexistent-user>
    <webmail>true</webmail>
    <spam-protect-sign>false</spam-protect-sign>
    </prefs>
    </set_prefs>
    </mail>
    </packet>
    EOP;
    ?>
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,564
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    What is result there when you select

    <webmail>true</webmail> or <webmail>false</webmail> in your API request?

    If I correctly understood Horde should be selected in 'true' case and None when you select 'false'?
     
  3. AronD

    AronD Guest

    0
     
    Thank you for your reply, When I run the packet on the API, the command seems to succeed but the webmail dropdown still shows as 'None' when I log into the Plesk control panel and view the mail preferences for the specified domain.
     
  4. AronD

    AronD Guest

    0
     
    More testing

    Ive tried runing the packet on the API and it seems to succeed without error but the drop down in the Plesk control panel still shows as 'None' for the domain in question.

    It would be really useful to be able to set this option to Horde either through the API or is there a way to set Horde as the default?
     
  5. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,564
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    'webmail' API option will not select Webmail application. It specifies whether mail users will have access to their mail via a WebMail application. I think that it is impossible to select Webmail application - Horde, Atmail or None via API request.
     
  6. Hultenius

    Hultenius Guest

    0
     
    That part of the documentation is not updated. I had the same problem a year ago.

    Use: <webmail>horde</webmail> or <webmail>none</webmail>
     
  7. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,564
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    I have forwarded corresponding request to developers.
     
Loading...