1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

AppStandard.org Wordpress Package Error (Application Vault)

Discussion in 'Plesk for Linux - 8.x and Older' started by schindyguy, Nov 5, 2010.

  1. schindyguy

    schindyguy Guest

    0
     
    I have a bunch of wordpress installs to deploy on a Media temple dedicated virtual server running Plesk 8.

    So I thought I would use the application vault to do a one click install of it...

    Since the wordpress package was for wordpress2.3 I wanted to update the package to the current wordpress 3.0.5. I went to "Upload new application distribution package" under Application Vault and used
    http://www.apsstandard.org/app/#pkg_vendor=wordpress.org&pkg_name=WordPress&pkg_ver=3.0&pkg_rel=5

    from appstandard.org site

    However, it gives me an error inside the Application Vault Menu:

    Warning: Unable to register the package located in the directory "WordPress-3.0-5": The uploaded application distribution package does not conform to the AppPacks specifications: DOMDocument::relaxNGValidate() [<a href='domdocument.relaxngvalidate'>domdocument.relaxngvalidate</a>]: Did not expect element id there.. You should remove the package from the server because it will not function properly.

    Anyone know what to do to modify the application package to allow it to work? I dont understand the specifications...

    Thanks
     
  2. OCOSAC

    OCOSAC Guest

    0
     
    work around

    As a work around you can:

    1. Navigate to /usr/local/psa/var/cgitory
    2. Find the package name and cd into it.
    3. rm -f APP-META.xml file
    4. done.

    Test out by logging into the admin panel and clicking on the application vault page, the warning should not reappear.

    NOTE:

    If you delete the folder then the warning will come back.
     
  3. KrazyBob

    KrazyBob Regular Pleskian

    27
    40%
    Joined:
    Nov 28, 2006
    Messages:
    141
    Likes Received:
    0
    So then how does one install the newer versions on Plesk 8.6 that has current versions of PHP and MySQL? We have licenses for Plesk 9 and 10 but that is another hassle for another thread :)
     
  4. OCOSAC

    OCOSAC Guest

    0
     
    I believe the answer would be you can't. You can do a manual install of the latest version for your clients but just out of the box with application vault nope. We actually ended up going to Plesk 9 was less of a hassle did not upgrade but built server and moved stuff over and created new accounts. Nasty move. The Plesk 8 was hosed.
     
  5. KrazyBob

    KrazyBob Regular Pleskian

    27
    40%
    Joined:
    Nov 28, 2006
    Messages:
    141
    Likes Received:
    0
    That's why we backed of v10.x. It was nothing but failure after failure. We had some failures on machines we did fresh installs on v9.3. I hate paying the SUS to get v9 when they can't get v10 to work correctly. Our biggest issue is sites that have been with us since Ensim. Encrypted passwords. Instead of generating a random password and emailing the site admin and email/web users they create a failure that they don't tell you until after hours if migrating. I am a programmer and have written conversion routines. First one checks what one has. See's what errors may occur, and go from there. But tis nonsense of hit and miss is ****. It ends up taking days for one successful migration and we have a lot of servers.

    The second issue is application templates that don't exist on the new server. One can rsync over the /vz/templates DIR but that doesn't always work.
     
  6. OCOSAC

    OCOSAC Guest

    0
     
    We use Plesk for clients we had since Plesk 8 but now that we use DirectAdmin and Website Panel for Windows no need for us to mess around with Plesk as much. I really like the look and feel of Plesk but we needed something that would script easy for clients so we went with DirectAdmin/Installatron works like a champ even on updates. Website Panel is great for Windows hosting. The only problem is support both panels and environments gets tedious at times.
     
Loading...