1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Open-Exchange 6.12 rel 2 - Catchable fatal error

Discussion in 'Plesk 9.x for Windows Issue, Fixes, How-To' started by SergeyA, Dec 11, 2009.

  1. SergeyA

    SergeyA Guest

    0
     
    I am trying to install Open-Exchange and it fails with an error.
    (http://www.apsstandard.org/app/#pkg...ndor=Open-Xchange Inc.&pkg_ver=6.12&pkg_rel=2)
    I am running Plesk 9.2.3 on a windows server 2008. For some reason, I cannot find Open-Exchange in the list of applications in the application vault, so I downloaded zip package from apstandard and trying to install it from local storage.

    Catchable fatal error: Argument 1 passed to XMLMetaNode::createFromXML() must be an instance of DOMNode, null given, called in C:\Program Files\Parallels\Plesk\admin\plib\SiteApps\FusionSiteAppMetaDataReader.php on line 352 and defined in C:\Program Files\Parallels\Plesk\admin\plib\SiteApps\FusionSiteAppMetaXML.php on line 41
     
  2. SergeyA

    SergeyA Guest

    0
     
    It looks like all packages with APS 1.1 or later fail with this message. I even tried to make my own package with 1.1 and 1.2 standards and they both failed with the exact same message.
     
  3. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,547
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
    The problem is that Parallels Plesk Panel does not support applications that have no htdocs directory. And Open-Exchange is such utility. In the latest version of Plesk the error that you see is replaced with the warning that it is not possible to install the utility. All applications available for installation can be found in Home > Application Vault > APS Catalog. All latest applications are available there.
     
  4. SergeyA

    SergeyA Guest

    0
     
    Thank you for your reply. I've already seen this exact message on a different thread, and i dont believe it applies to this particular case, because i do have htdocs in my custom package that i built yet it still generates this exact same error.
     
Loading...