1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

assembly's manifest does not match reference

Discussion in 'Plesk for Windows - 8.x and Older' started by inCharge.co.uk, Aug 23, 2006.

  1. inCharge.co.uk

    inCharge.co.uk Guest

    0
     
    The Plesk 7.5.1 Backup utility on my Win2003 server has stopped working and I need some help to get it going again.

    The backup utility outputs this message:

    "The located assembly's manifest definition with name 'ICSharpCode.SharpZipLib' does not match the assembly reference."

    It's using that component to zip up files for backup. This started happening after I unzipped a file on the server using WinZip, which is a bit too much of a coincidence. The only other thing I can think of that might have caused it is Window Updates. I hadn't touched the Plesk installation for ages because upgrading it is a nightmare.

    I found the component in the fllowing folder. There is only one instance of it on the machine:
    C:\Program Files\SWsoft\Plesk\admin\bin\ICSharpCode.SharpZipL ib.dll

    The file version number is: 0.6.0.0

    The name appears in the registry under many classes like so:
    HKEY_CLASSES_ROOT\CLSID\{03C8F70E-6470-35C8-A387-ED4FB9B1C96D}: ICSharpCode.SharpZipLib.Tar.TarHeader
    HKEY_CLASSES_ROOT\CLSID\{03C8F70E-6470-35C8-A387-ED4FB9B1C96D}\InprocServer32\Assembly:
    ICSharpCode.SharpZipLib, Version=0.8.1903.26768, Culture=neutral, PublicKeyToken=null

    So why is the version number different? Is this the problem? I tried un-registering and re-registering the component with regasm, which gave 'Success' messages but still get the problem.

    To get more debug information I added to the registry:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Fusion\LogPa th = c:\log
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Fusion\Force Log = 1

    Running backup again produces several files in the log folder including:
    FusionBindError!exe=backup.exe!name=ICSharpCode.Sh arpZipLib, Version=0.8.1903.26768, Culture=neutral, PublicKeyToken=null.HTM

    Which contains:
    *** Assembly Binder Log Entry (21/08/2006 @ 09:16:55) ***

    The operation failed.
    Bind result: hr = 0x80131040. No description available.

    Assembly manager loaded from: C:\WINNT\Microsoft.NET\Framework\v1.1.4322\fusion. dll
    Running under executable C:\Program Files\SWsoft\Plesk\admin\bin\backup.exe
    --- A detailed error log follows.

    === Pre-bind state information ===
    LOG: DisplayName = ICSharpCode.SharpZipLib, Version=0.8.1903.26768, Culture=neutral, PublicKeyToken=null
    (Fully-specified)
    LOG: Appbase = C:\Program Files\SWsoft\Plesk\admin\bin\
    LOG: Initial PrivatePath = NULL
    LOG: Dynamic Base = NULL
    LOG: Cache Base = NULL
    LOG: AppName = NULL
    Calling assembly : psabackupfile, Version=1.0.1903.26770, Culture=neutral, PublicKeyToken=null.
    ===

    LOG: Processing DEVPATH.
    LOG: DEVPATH is not set. Falling through to regular bind.
    LOG: Policy not being applied to reference at this time (private, custom, partial, or location-based assembly bind).
    LOG: Post-policy reference: ICSharpCode.SharpZipLib, Version=0.8.1903.26768, Culture=neutral, PublicKeyToken=null
    LOG: Attempting download of new URL file:///C:/Program Files/SWsoft/Plesk/admin/bin/ICSharpCode.SharpZipLib.DLL.
    LOG: Assembly download was successful. Attempting setup of file: C:\Program Files\SWsoft\Plesk\admin\bin\ICSharpCode.SharpZipL ib.DLL
    LOG: Entering run-from-source setup phase.
    WRN: Comparing the assembly name resulted in the mismatch: PUBLIC KEY TOKEN
    ERR: The assembly reference did not match the assembly definition found.
    ERR: Failed to complete setup of assembly (hr = 0x80131040). Probing terminated.


    So the Public Key Token is bad? How do I fix this?

    Thanks,
    Julian
     
  2. inCharge.co.uk

    inCharge.co.uk Guest

    0
     
    Obviously not one of those problems you go "oh yeah, I know that one..."

    Fortunately I have a Plesk support contract with Sw-soft and they fixed it. Never found out the cause or solution but all is working now.
     
Loading...