1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

atMail - can not send messages

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by kaizer, Dec 12, 2008.

  1. kaizer

    kaizer Guest

    0
     
    I finally activated atMail webmail, and now I get this error message when sending:

    553 sorry, that domain isn't in my list of allowed rcpthosts

    Anyone knows what causes this? And how to correct it?
     
  2. JadeAT

    JadeAT Guest

    0
     
    Same issue

    I'm having the same issue trying to send an email using atmail. I can send it fine using my mail client. This is a new install of atmail. Thank you.
     
  3. visbits

    visbits Guest

    0
     
    Yes, everyone is having this issue. Its a problem with the atmail addon. Horde mail works perfectly fine, Although I think most of us prefer the interface for atmail.

    I hope that Parallels address the problem quickly. Plesk 9 is very very very nice!
     
  4. 2dareis2do

    2dareis2do Guest

    0
     
    Yeah.

    switched to atmail because horde wasn't working and now I too get this error:

    Could not send message to SMTP server. Check you have access to send messages via the server and that all To/CC/BCC addresses are valid\nError: SMTP Server rejected email. Returned:553 sorry, that domain isn't in my list of allowed rcpthosts (#5.7.1)
     
  5. 2dareis2do

    2dareis2do Guest

    0
     
    A problem shared

    I managed to change the sendmail from Qmail to postfix. This did not fix the problem, but did give me some more info:

    Could not send message to SMTP server. Check you have access to send messages via the server and that all To/CC/BCC addresses are valid\nError: SMTP Server rejected email. Returned:554 Service unavailable; Client host [127.0.0.1] blocked using list.dsb.org

    list.dsb.org is used as part of the option to Switch on spam protection based on DNS blackhole lists.

    list.dsb.org is one of the DNS zones used by the DNSBL service

    Therefore I have switched this off and voila, Atmail is now sending emails to external sites without any problems.

    I am not sure though if this is because of this particular DNS zone or the service in general?

    Horde is still not working either.
     
  6. 2dareis2do

    2dareis2do Guest

    0
     
    DNS Zones for DNSBL

    This problem seems to be isolated to one of the DNS zones for DNSBL service. I have this taking out list.dsb.org and it now seems to working fine.

    Hope this helps someone.
     
  7. vierupro

    vierupro Guest

    0
     
    Had the same error after @mail upgrade:
    Seemed like @mail didn't authenticate when trying to send the email. After searching through the sources found that in the @mail config file (/var/www/atmail/libs/Atmail/Config.php) there is an option to authenticate with an username/password
    'smtpauth_password' => '',
    'smtpauth_username' => '',

    by default they're empty.
    if you put here a valid username and password, the messages will be sent.
    The problem is that I wanted that the users authenticate with their own credentials when sending messages.

    So here's the way I fixed it:

    Open the file /var/www/atmail/libs/Atmail/SendMsg.php

    Search for the line "// Optionally authenticate with the SMTP server"
    (it's about line 740)

    Add bellow:
    That's it. This will override the auth settings from Config.php with the credentials the user used to log in.


    Hope that will help the others.
     
  8. kevork

    kevork Guest

    0
     
    Nice Hack

    Thank you!, it worked for me and saved melot of time.
     
Loading...