1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

autoreport.php causing server to hang

Discussion in 'Plesk for Linux - 8.x and Older' started by tjohnson, May 31, 2005.

  1. tjohnson

    tjohnson Guest

    We are running 7.5.3 on a Dell server. We have now had the server hang 3 times in the last two months...each time on a Monday morning while it was running the autoreport.php --auto weekly function in cron.

    Is this a known problem? I have two servers, but only 1 server seems to show this problem... however, there are no error messages in any log files. The server requires a hard reboot and then seems to come back up fine.
  2. edispah

    edispah Guest


    Were having exactly the same problem.

    We have Plesk 7.5.3 on Fedora Core 2 running on a Dell server. Every monday morning we have to do a hard reboot - the box seems to die about 7:20am

    I cant see anything in any logs and the only script I can find that runs about that time is in crontab at 7:17am

    /usr/local/psa/admin/bin/php /usr/local/psa/admin/plib/report/autoreport.php --auto weekly > /dev/null 2>&1

    Did you find a solution to this problem?


    Paul Houselander
  3. Traged1

    Traged1 Guest

    First I would remove the > /dev/null 2>&1 part to see if you can get an email which may contain clues.

    I would also suggest you run a strace /usr/local/psa/admin/bin/php /usr/local/psa/admin/plib/report/autoreport.php --auto weekly to see if you can find out where it is crashing. You may be running into a memory squeeze or lack of memory which may cause a kernel panic. Do you have any Opps messages on the screen when it crashes?
  4. basic612

    basic612 Guest

    hi - this is happening to us on a plesk 8.0 server. The server is locking up at 7:17am on the dot every monday morning.

    it's a shame that nobody has reported back their findings on this problem

    I have tried running the command using strace but end up with this message:

    waitpid(5273, DEBUGGER DETECTED... Bye!

    does this mean that autoreport.php can not be run with strace - due to the Zend Guard encryption?

    I have tried to run the report manually from the commend line and it works with no problems

    not too sure where to go here apart from disabling the weekly and monthly reports.
  5. Traged1

    Traged1 Guest

    Have any of you reported this to PLESK support?
  6. basic612

    basic612 Guest

    well, that is my next step.

    I have found that it helps to be well researched before posting a request to the official support channels :)
  7. Hostasaurus@

    Hostasaurus@ Guest

    Have you guys found anything on this? We've got a Dell 2850 doing the same thing with 7.5.4 but like some of you, we've got numerous identical systems that don't do this.
  8. basic612

    basic612 Guest

    Hi - no progress on this so far from my end. I tried to report it to Plesk support but they referred me back to the hosting company that is leasing the license to us as the Plesk honeymoon support period has expired. Unfortunately the hosting support people are not really able to help much in tracking this down as they've not seen it happen before and know about as much as I do from reviewing the forums...

    This issue is proving very hard to nail down, I have run the weekly report manually with no problems. I also suspected that the problem may be related to the daily and weekly reports being triggered at the same time, but have not managed to reproduce this - ie. when setting up both reports to run while I was on hand to reboot server in case of lock up, the result was only a fresh batch of reports delivered to my mailbox.

    This is a bit perplexing - the server in question is only experiencing relatively low traffic at the moment, httpd log files in the order of 32Mb and maillogs are small... 6Mb at the moment. I have cacti graphs monitoring various metrics on the server and it is pretty much idling at the point that the weekly report script starts up.

    Looking forward to someone making some progress on this and sharing the joy :)
  9. akumarjain

    akumarjain Guest


    I am using Plesk 7.5.4 with FC3. For me it's not daily cron jobs which are causing my server to hang almost daily. After watching 2-3 days and being confirmed that it's daily cron jobs, I do SSH into my server and then monitor server activity using TOP. Surpirisingly, the day I use to monitor using TOP, server doesn't hang but the activities it shows are mind boggling. At the time cron jobs are running, CPU usage goes up to 90% and server load also sky rockets. Even a small APACHE routine (httpd request) takes up 25% CPU usage.

    Is this normal??

    I would suggest other members facing this problem to TOP their server at the time of cron jobs running and share the results. And, if anyone can come up with some solution??
  10. baguitos

    baguitos Guest

    I have the same problem here.

    The server is locking up at 7:17am on the dot every monday morning :(

    I’ve disable (in PLESK 8.0) this task.

    Will this solve the problem, or should I expect more problems next monday morning :confused: :confused:
  11. akumarjain

    akumarjain Guest

    Sorry, forgot to update on this topic. I checked another friend's server and found some differences between both server's cron jobs execution order. I changed the order of my server's cron job and since then it's working fine now. I guess, mainly it's 'prelink' program whose order matters in comparison to other programs (cron jobs).

    Hope this helps.
  12. baguitos

    baguitos Guest

    Another question (it could be dumb, but I’m new in PLESK):

    This autoreport.php thing, what’s the utility? By disabling it (the weekly task), what am I missing? Should I be getting a daily report as well?
  13. basic612

    basic612 Guest


    Hi akumarjain,

    this sounds interesting - my cron jobs were system default ones. Are you able to post what your job order was previously, and what you changed it to in order to get the jobs to behave?

  14. ldejager

    ldejager Guest

  15. knocx

    knocx Guest

    we are actually getting the same error weekly each monday
  16. knocx

    knocx Guest

    anyone managed to solve this issue?

    i have CentOS 4.4 x 5 PLESK 8.0 servers they are all exactly same.

    The strange thing is that only one of these servers crashes each monday at 07:17 AM,

    i see that the problem is related with the argument --auto weekly . it seems there is a bug occurs in rare cases.

    and i track this issue since 7.5 , that stands for ; there is a problem and plesk still is not auditing it for a fix.

    why will removing /dev/null 2>&1 fixes the issue for the crashing server,isnt this just to nullify the stdout and not to receive an email.

    my other 4 servers still has /dev/null 2>&1 at the end and works properly without any crash
  17. ldejager

    ldejager Guest

    All CentOS servers running the same kernel?

    I found that when I upgraded the kernel on the problem server the lockups disappeared.

  18. knocx

    knocx Guest

    yep All kernels are same...

    On the otherhand this should not be a kernel related issue rather it seems to be a programmatic issue ,

    how did you conclude on that? , also why not daily and monthly arguments not crashing the server?
  19. Hostasaurus@

    Hostasaurus@ Guest

    It's a kernel issue in that whatever autoreport is doing, it shouldn't be able to kill the box. It's a SWSoft issue that it's occurring though, not that they'll ever fix it.
  20. knocx

    knocx Guest


    if this is a kernel issue why can not we replicate the issue on the other servers then?

    they all have

    -same OS
    -same PLESK
    -same "Kernel"
    -same Memory
    -same CPU
    -same drives
    -Same everything