1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Awstats 404 Error

Discussion in 'Plesk 9.x for Windows Issue, Fixes, How-To' started by Rob Collins, May 13, 2010.

  1. Rob Collins

    Rob Collins Guest

    0
     
    The default statistics page for a domain loads OK (/plesk-stat/webstat/). But when another month or year is selected and we click on the OK button, we get a 404 Not Found error (/plesk-stat/webstat/AWStats/cgi-bin/awstats.pl).

    I have already confirmed that Perl is enabled for this domain, as in this KB: http://kb.odin.com/en/1083.

    I have tried removing awstats for the domain, then re-adding it, but we still have the problem.

    We have this problem on every domain on the server.

    What other causes are there for this error?
     
  2. AndreaV

    AndreaV Guest

    0
     
    Same problem

    Have you found a solution? I'm having exactly the same problem. Please help..
     
  3. AndreaV

    AndreaV Guest

    0
     
    Have you found a solution? I'm having exactly the same problem. Thanks
     
  4. VladimirL

    VladimirL Guest

    0
     
    If you are running the Windows machine, check your domain configuration in IIS and try to disable/remove any ISAPI rewriters related to the domain.
     
  5. Tamouh Hakmi

    Tamouh Hakmi New Pleskian

    22
    57%
    Joined:
    Mar 30, 2009
    Messages:
    15
    Likes Received:
    0
    Fix for IIS 7.5

    We found the solution for IIS 7.5. It is a bug in Plesk, it seems that Plesk has the following Executable Path set for *.pl :

    C:\Program Files (x86)\Parallels\Plesk\Additional\Perl\bin\perl.exe "%s" %s

    According to MSFT/IIS , if the path contain spaces, it should be enclosed with quotation marks as such:

    "C:\Program Files (x86)\Parallels\Plesk\Additional\Perl\bin\perl.exe" "%s" %s

    This setting can be modified by opening IIS Manager -> Sites -> open the site you wish to modify -> click on Handler Mappings -> look for the line with the extension *.pl, highlight and hit on Edit at the right side, go to the section to change execute command path.

    Once you hit OK to save, it may ask you to allow the ISAPI extension for that script, makes sure to say YES.
     
Loading...