1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

AWStats on 1and1 VPS Server

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by sthomas, Oct 13, 2009.

  1. sthomas

    sthomas Guest

    0
     
    Hi,

    I'm running Plesk 9.2.2 and have a number of domains configured on the system. I have two questions:
    * How do I access the statistics? - I get the 403 Forbidden message (I've included further info below)
    * How do I change the link in the domain control panel from http://tld.com to http://www.tld.com?

    Message: "You don't have permission to access /plesk-stat/webstat on this server."
    statistics 4.00 KB r-x r-x --- Sept 28, 2009 root psaserv

    Plesk seems to need to have read and write to everyone for sites like Joomla. What user does httpd run as? Does this user have permissions or membership of the Plesk groups etc? I'm a little confused about how all the permissions work.

    Can anyone help shed any light on this for me... there's lots of sites out there but with very confusing comments and little on Plesk 9.

    Thanks,
    Steve
     
  2. igors

    igors Basic Pleskian

    20
    37%
    Joined:
    Sep 1, 2009
    Messages:
    32
    Likes Received:
    0
    Hi,

    To add 'www' to domain name go to Domains > select domain. On domain general page click on Domains administration drop down menu > Rename domain > mark 'www' checkbox > Save

    To correct 403 error when accessing statistics try the following:
    1. Reconfigure apache settings for all domains on server and reload apache to reflect changes:
    /usr/local/psa/admin/sbin/websrvmng -v -a

    2. If it does not help then from Parallels Plesk panel > Domains > select domain > Web hosting settings > Uncheck 'accessible via password protected directory '/plesk-stat/webstat/' (if it is unchecked, check it) > click OK and then switch it back.

    3. Create backup copy of domain web content (usually located in /var/www/vhosts/DOMAIN_NAME). When copying domain content use '-p' option to preserve content permissions.

    Now run the following command to make Parallel Plesk reset permissions on domain content:
    /usr/local/psa/admin/sbin/vhostmng --install-vhost --vhost-name=DOMAIN_NAME --user-name=DOMAIN_FTP_USERNAME --set-content-permissions

    Hope this helps.
     
Loading...