1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

backup breaking

Discussion in 'Plesk for Linux - 8.x and Older' started by Artur, Jun 14, 2005.

  1. Artur

    Artur Guest

    0
     
    When I run backup:

    ===========================
    dumping crontab of user1
    dumping crontab of lastuser2
    Can't call method "isDocumentFragmentNode" without a package or object reference at /usr/local/psa/lib/perl5/site_perl/5.6.1/XML/DOM.pm line 623.
    ===========================

    All perl packages were reinstalled, even downgraded perl. Reinstalled psa-bu.

    Any ideas?
     
  2. voodoochile

    voodoochile Guest

    0
     
    Do you have the entire XML::DOM package installed? You might grab it via CPAN just to make sure.

    'perl -e shell -MCPAN' go through the config , the defaults are fine (you may not need to go through the config' then do an
    'install XML::DOM'

    Verify that it installs properly, if not, you'll need to change to the build directory (usually /root/.cpan/<something> you'll see it in the error) and do a 'make; make install' in there.
     
  3. Artur

    Artur Guest

    0
     
    No luck, I have already tried reinstalling all XML rpms.
     
  4. Artur

    Artur Guest

    0
     
    Here is the fix from PSA support. Replace this file with the attached file:
    /usr/local/psa/lib/perl5/BU/PSA/Backup/Ver0600toXML.pm
     
  5. Artur

    Artur Guest

    0
     
    I guess this forum does not allow attachments, here is what you do:

    in file: /usr/local/psa/lib/perl5/BU/PSA/Backup/Ver0600toXML.pm

    Line 2351:
    remove:
    replace:
     
  6. Mr.Yes

    Mr.Yes Guest

    0
     
    Hi Artur,

    thank you so much for your help, everything is back to normal now after the hack of that file.

    My question is: why at sw-soft allow to a stupid perl file to hangs their backup solution? :)
     
  7. Artur

    Artur Guest

    0
     
    I think they have something going on behind the scenes and there is a shakeup with the developers. Look at how many problems there were with the 7.5.3 update. I think they rushed it, got their asses handed back to them by their customers, and now they will have to make sure the next few releases go smoother or risk alienating their customer base.

    But to be fair, after pulling my hair out for a few days and trying to hack the backup into working, I got in touch with their support and within an hour they handed me the solution.
     
Loading...