1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

BakupAgent

Discussion in 'Plesk for Linux - 8.x and Older' started by SimonSchmitz, Jan 26, 2007.

  1. SimonSchmitz

    SimonSchmitz Guest

    0
     
    DBI connect('dbname=psa;host=localhost','admin',...) failed: Client does not support authentication protocol requested by server; consider upgrading MySQL client at /opt/psa/PMM/agents/shared/Db/DbiBackend.pm line 43

    from dotdeb
    mysql server 5.0.32
    mysql common 5.0.32
    mysql client 5.0.32
     
  2. simonmango

    simonmango Guest

    0
     
    Update MySQL Client

    I had a similar problem with MySQL4.1 after updating Plesk. I tried all the tricks like changing the MySQL Admin user's password to the old style, adding old_passwords = 1 in my.cnf etc. but these did not work for me (CentOS 3.6 / Plesk 8.1).

    Eventually I decided to try and update the Perl MySQL client.

    After lots of digging and frustration I found 2 web pages that helped:
    http://dev.mysql.com/doc/refman/5.0/en/perl-installation.html
    http://www.arcknowledge.com/gmane.comp.db.mysql.documentation/2005-06/msg00003.html

    I've never really messed about with Perl and it's libraries here so use the solution below with caution/backup/etc.

    When logged in as root:

    shell> perl -MCPAN -e shell
    cpan> o conf makepl_arg "--testpassword=rootpassword"
    cpan> install DBD::mysql

    You may have to do a force install:

    cpan> force install DBD::mysql

    Obviously you must replace "rootpassword" above with the password of the MySQL root user.

    Hope this helps someone.
     
Loading...