1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Beware psadump doesn't back everything up

Discussion in 'Plesk for Linux - 8.x and Older' started by kabarty, Jan 29, 2005.

  1. kabarty

    kabarty Guest

    0
     
    I've lost files and directories from my system as I did a full (or so I thought) backup using psadump, and when I've restored it after wiping the system, there's various files and folders underneath the vhosts tree that are missing.

    Basically it would appear that anything that doesn't have exactly the right set of permissions or something that's added using a system login isn't backed up.

    I've lost shell scripts that I use to run my site, I've lost customer data that they've put up using FTP. This is totally and utterly freaking unacceptable. psadump never warned me of things it couldn't backup, it said everything went fine. psarestore said the same thing too.

    What am I suppose to tell my customers?

    So the moral of the story is, don't use psadump and psarestore by the looks of it. I'd have been better off using tar and just archiving up the database directory.
     
  2. sieb@

    sieb@ Guest

    0
     
    It can't backup what it doesn't have permission to touch.
     
  3. kabarty

    kabarty Guest

    0
     
    I ran it as root.

    Furthermore, as a backup tool I expect it to alert me if there is something it cannot touch, not just blindly say 'Yeah guys, I backed everything up for you' when it fact it didn't
     
  4. microsol

    microsol Guest

    0
     
    DON'T wipe out your backup file(s) yet!!!

    We had once the same. The backups were around 45GB but after a restore about 30GB were missing on the restored server.
    A selective restore (domain after domain) should help to restore everything. At least it did with us.. .
     
  5. gper

    gper Guest

    0
     
    Restore

    Hi guys,
    i have the same problem.

    Did somebody find a solution for the restore ?

    Psa restore , does not restore the data of the /vhosts/domain..
    directories.


    Jerry
     
  6. tieten

    tieten Guest

    0
     
    As far as backing up my system is concerned I would rather trust my grandma than SW-Soft.
     
  7. Synetec

    Synetec Guest

    0
     
    ohh, i read only problems with backups psadump or tbackup and lost data by restore.

    ok, so i make a full psadump on every night, a full tar with tbackup every night and a cp -a every night.

    So my server make three backups every night and he working over 10 hours by night for this. But i think, by 3 ways, thats like a raid-5-backup, but the different, on raid-5 system crash two harddisc all data lost, by my raid-5-backup i have three chance to restore it.

    Thats crazy, but i read every problems here and with my reason i can happy sleeping every night.
     
  8. kengtay

    kengtay Guest

    0
     
    I have used the Backup from plesk, 1and1 reimage my root server, How can I restore it back? if not, what can I do with the backup file ?
     
  9. reiberjoe

    reiberjoe Guest

    0
     
    how exactly did you do that?
    did you re-image the server before? or did you leave the "corrupt restore" and just restored the single domains on top of that?
     
  10. acidbox

    acidbox Guest

    0
     
    Hah! They aren't THAT bad! ;)

    We do a full psadump, but we also tar each domain individually just for safe keeping. It makes it easier to retreive data anyway.
     
  11. tcong

    tcong Guest

    0
     
    Backing up hang the server every now and then

    I have similar problem with backups.

    I have configure individual domains with schedule backup and sometime it hangs the server. It happened every 4 or 5 days after each server cold reboot!

    Look like the backup process is not very stable. I deduce that the server hangs during backup process as the server did not complete sending email notification upon successful backup of each domain. It stopped in between list of domains scheduled for backup.

    Any advise what could be wrong?

    Can anyone share the TAR backup scripts? I really need alternative backup plan.

    ______
    Plesk Reloaded 7.5.4
    RHEL3 64-bit
    PHP 4.3.11
    MySQL 3.x
     
  12. thewolf

    thewolf Regular Pleskian

    25
    57%
    Joined:
    Mar 11, 2004
    Messages:
    231
    Likes Received:
    0
    Hi,

    We're also seeing the issue with psadump not saving all files (some domains httpdocs directories are empty, so are some mailboxes).

    Did anyone ever figure out a fix for this?

    Thanks.
     
  13. azur99

    azur99 Guest

    0
     
    Files missing in domain backup

    i have the same problem here.

    i have a domain with lots of jpegs (around 1 GB) here, but the backup file - either created from plesk web interface or with the CLI utility - is only 160MB.

    So appearantly something is missing.
    i checked the permissions, ftpuser of this domain has read & write permission on all files. i ran the cli command as root, but that does not make a difference.

    if i backup the whole server with CLI, the files are included, because the backup file has the expected size then.
     
Loading...