1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Browser Cache with mod_expires

Discussion in 'Plesk 11.x for Linux' started by Taimon, Nov 29, 2012.

  1. Taimon

    Taimon New Pleskian

    10
    85%
    Joined:
    Oct 8, 2012
    Messages:
    14
    Likes Received:
    0
    Hi,

    I have the problem whit die Browser Cache from my website.
    I have greatet a .htaccess whit follow inputs:
    <IfModule mod_expires.c>
    ExpiresActive On
    ExpiresDefault "access plus 1 month 1 days"
    ExpiresByType text/html "access plus 1 month 1 days"
    ExpiresByType image/gif "access plus 1 month 1 days"
    ExpiresByType image/jpeg "access plus 1 month 1 days"
    ExpiresByType image/png "access plus 1 month 1 days"
    ExpiresByType text/css "access plus 1 month 1 days"
    ExpiresByType text/javascript "access plus 1 month 1 week"
    ExpiresByType application/x-javascript "access plus 1 month 1 days"
    ExpiresByType text/xml "access plus 1 seconds"
    </IfModule>

    With this .htaccess can't running the browser caching, i have test very much other configuration but the browser caching can't running.
    My problem is, is running the mod_expires.c in plesk now, or must I change the configuration?
    What can i do that the browser caching running on my server?
    My Configuration is:
    BS CentOS 6.3 (Final)
    Panel-Version 11.0.9 Update #28

    Best Regards
     
  2. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    You need to be running php as an apache module, are you?
     
  3. lvalics

    lvalics Silver Pleskian Plesk Guru

    36
    43%
    Joined:
    Jun 20, 2003
    Messages:
    965
    Likes Received:
    32
    Location:
    Romania
    I can suggest:

    Install mod-pagespeed for APACHE.
    This module can speed up your pages a lot.
    yum install at
    rpm -Uhv https://dl-ssl.google.com/dl/linux/direct/mod-pagespeed-stable_current_x86_64.rpm
    If all goes well, the module is already installed now, just restart apache. You can check if exist /etc/httpd/conf.d/pagespeed.conf Also you can play with this conf file as you like to test the best performance. Eventually I prefer to deactivate ModPagespeedStatistics OFF
     
  4. Taimon

    Taimon New Pleskian

    10
    85%
    Joined:
    Oct 8, 2012
    Messages:
    14
    Likes Received:
    0
    Hi

    I have change the settings to apache module in Service Packages, Hosting Parameter.
    Before is was FastCGI.
    I hope you mean this?

    I have restart the apache but it's still not suffer.
    To what it might be yet?

    Thanks for your help!
     
    Last edited: Nov 30, 2012
  5. Taimon

    Taimon New Pleskian

    10
    85%
    Joined:
    Oct 8, 2012
    Messages:
    14
    Likes Received:
    0
    Ok Thanks i will test this, is this not a problem with Plesk?
     
  6. Taimon

    Taimon New Pleskian

    10
    85%
    Joined:
    Oct 8, 2012
    Messages:
    14
    Likes Received:
    0
    Unfortunately I have not found a solution, someone has an idea?
     
Loading...