1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Can I downgrade back to 7.5.2?

Discussion in 'Plesk for Linux - 8.x and Older' started by msteudel, Jun 4, 2005.

  1. msteudel

    msteudel Guest

    0
     
    I tried upgrading from 7.5.2 to 7.5.3 and I am getting the blank plesk screen. Is it possible to just go back into the 7.5.2 and install all the rpm's or am I asking for trouble trying that. Any ideas on how to downgrad back to 7.5.2?

    Thanks, Mark
     
  2. philjohn

    philjohn Guest

    0
     
    I had a problem during the upgrade to 7.5.3 which left my system totally down (i.e. all apache vhosts configs hosed, so 100 sites where down). I fixed it as follows (I may write this up into a detailed howto at a later date, here's the cliffsnotes version).

    First of all, remove all plesk rpm's, start by doing a

    rpm -qa | grep psa

    to get the main ones, then you need to remove ones that depend on psa, so that's

    rpm -e psa-api-common psa-api-cli psa-api-rpc --nodeps

    now try

    rpm -e psa

    you'll get a load of dependency errors, simply add all of these to the list, i.e.

    rpm -e psa psa-migration-manager psa-bu etc. etc.etc

    You may get a load more dependancy errors, these are mostly application vault packages (if you have them installed not a good idea as i doubt they get timely security updates), add those to the list too. if you still get errors add a --nodeps to the end at this point.

    Now comes the fun part, you need to restore the psa database (mysql database where plesk stores hosting data) to the last good dump (plesk makes a dump of all databases every night). The files are called mysql.daily.dump.X.gz where X is the age (in days) of the dump, get the last known good dump (i.e. if the problems started 3 days ago after the dump file was created get mysql.daily.dump.3.gz, in the following example that's the one we'll use.

    cd /var/lib/psa/dumps

    cp mysql.daily.dump.3.gz /tmp

    cd /tmp/

    gunzip mysql.daily.dump.3.gz

    Now we need to remove the current databases (may have been left in an inconsistent state by the autoupdater that for some reason best known to SW-SOFT simply borks at errors instead of backing out and restoring the system to the previous working state, but that's a rant for another day)

    So, the long and the short of it is you need to lose the horde and psa databases, launch the mysql admin tool:

    mysql -u admin -p`cat /etc/psa/.psa.shadow`

    DROP DATABASE horde;

    DROP DATABASE psa;

    quit

    (the ; is important as it signals the end of the command.)

    Now we need to reload the working db

    mysql -u admin -p`cat /etc/psa/.psa.shadow` < mysql.daily.dump.3

    now go and get the autoinstaller for 7.5.2 (or do a yum install psa via Atomic Rocket Turtle's yum archive which IIRC still has the 7.5.2 rpm's) and all should be good.

    As always when trying to fix sw-softs installation issues, YMMV.
     
  3. msteudel

    msteudel Guest

    0
     
    Awesome thank you!
     
  4. philjohn

    philjohn Guest

    0
     
    you're welcome, let me know if it works out for you, I had a frantic 30 minutes when one of my 8 upgrades went pear-shaped :rolleyes:
     
  5. siren@

    siren@ Guest

    0
     
    The Horde database isn't as much of a problem in a failed upgrade as the PSA database.

    Due to this Plesk makes a preupgrade dump file in /var/lib/psa/dump that you can dump the PSA database and restore this to the server.
     
Loading...